Can't get subdirectory index to work...

Discussion in 'General' started by Stokesy, Sep 22, 2016.

  1. Stokesy

    Stokesy Member

    Can anyone help?
    I have tried everything I can think of to allow the contents of a subdirectory (and the directories beneath it) to be visible to users...
    I have added various directives to the apache options on ispconfig 3 like:
    <Directory "/var/www/clients/client8/web32/web/v1/mm-docs">
    AllowOverride All
    Options +Indexes
    ...with and without quotes and using the symlink instead of the direct path...
    I've tried directly modifiying the vhost file in sites-available...
    I've tried putting .htaccess file in mm-docs ...
    None of these work - I just get 404 errors...

    Help - what's should have taken me five minutes is taking me hours!!!
  2. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    Make sure mod_autoindex is enabled (a2enmod autoindex).
  3. Stokesy

    Stokesy Member

    Bravo Jesse - that did the trick! :)

Share This Page