Cant log in as Admin

Discussion in 'General' started by brosch, Jun 7, 2007.

  1. brosch

    brosch New Member

    Hi everyone.

    I've just "inherited" the ISPConfig server here. When I try to enter the supplied password, I get an ERROR 101: Wrong user name or password.

    I've contacted the previous person (not very helpfull), and tried the other values he suggested. None worked.

    I do have access to the machine, and can signon to it. It's an Ubuntu 6.10 perfect server setup.

    Can anyone give me a hand here, please?

  2. edge

    edge Active Member Moderator

    I'm just double checking here..
    What are your trying as login name / password?

    Standard it's, name: admin password: admin
  3. brosch

    brosch New Member

    The username wasn't changed (so I've been told). The password was. I've tried what it was supposed to be, and what the previous person thought it might be (this is just one reason why it's a previous person...).

  4. edge

    edge Active Member Moderator

    Last edited: Jun 7, 2007
  5. brosch

    brosch New Member

    ISPConfig was installed several months ago. The person who installed it & who also changed the passwords has left. The password that he supposedly changed it to did not work, nor did the several passwords that he thought it might have been changed to.

    In effect, we have a running system that we cannot access at the admin level (with respect to ISPConfig).

    Is there any way to reset the admin password back to it's default? We do have root access on the actual server.

  6. mlz

    mlz New Member

    using the thread that Edge mentioned, you can use the MySQL CLI monitor to update it as followed
    # mysql db_ispconfig -p
    Enter password: <type in the root password>
    UPDATE sys_user SET passwort = md5('myNewPassword') WHERE username = 'admin';
    Obviously change myNewPassword to what you want the password to be. You can get the password as mysql user by doing the following:

    grep db_user ~admispconfig/ispconfig/lib/ ; grep db_password ~admispconfig/ispconfig/lib/ ; grep db_dbname ~admispconfig/ispconfig/lib/
    That should get you the info to into the DB and allow you to do the update. If the third line is not set to db_ispconfig then substitute the setting that is shown in the grep statements.
  7. brosch

    brosch New Member

    Edge & MLZ,

    The instructions worked great. I've now got full access.
    Thank you very much for your help.


Share This Page