Can't log in to admin panel... MySQL?

Discussion in 'General' started by blaszlo, Jan 7, 2009.

  1. blaszlo

    blaszlo New Member

    hey guys,

    i had my server rnning great for a while, and i took it offline for about a month and just got it back up. I am attempting to login to myadmin panel and for some reason, it gives me the following error...

    Warning: mysql_connect() [function.mysql-connect]: Can't connect to MySQL server on '' (4) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

    Warning: mysql_connect() [function.mysql-connect]: Can't connect to MySQL server on '' (4) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/web/login/login.php on line 62

    What does all this mean? Any help in getting this to work again would be great! PS: I tried service mysqld start and that did nothing...
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that the mysql server is not started.

    Please take a look in your syslog or messages log why mysql does not start.
  3. blaszlo

    blaszlo New Member

    where is my syslog and messages log? im sorry, but im pretty new to this.
  4. falko

    falko Super Moderator ISPConfig Developer

    They are in the /var/log directory.
  5. kerl1234

    kerl1234 New Member

    sorry to dig up such an old topic, but i ran into the same errormessages.

    my problem is, that i can't tell from the log, whether the MySQL service is started or not, it merely states shutdowns even if i restart MySQL form the konsole.

    is there any way to tell if a certain DB is not running?

    oh, and shouldn't there be an error in the installation of ispconfig, if the entered login-information is incorrect?

  6. Hans

    Hans Moderator ISPConfig Developer

    I think your MySQL server is not running indeed, but what is the output of the command:
    netstat -tap | grep mysql

  7. kerl1234

    kerl1234 New Member

    tcp 0 0 *:mysql *:* LISTEN 6097/mysqld

    #mysqladmin ping gives me:
    mysqld is alive
    Last edited: Sep 11, 2009
  8. falko

    falko Super Moderator ISPConfig Developer

    MySQL seems to be up and running.
  9. kerl1234

    kerl1234 New Member

    thnx, at least i didn't act fully stupid, but is there an explenation for these errors, i keep getting? and maybe even a solution?

    could the reason be some error in the mysql-input provided during the ispconfigsetup? (and if: how would i fix it?)
  10. falko

    falko Super Moderator ISPConfig Developer

    Does the ISPConfig login work?
    Which distribution are you using?
  11. kerl1234

    kerl1234 New Member

    I run OpenSuSE 10.3 (since I plan on using Novells iFolder).

    About the login i can only say, that this is what produces these errors.
    The loginpage itself can be accessed and logininformation can be entered, but no login takes place, instead i'm directed to the list of errors.
  12. falko

    falko Super Moderator ISPConfig Developer

    Are the MySQL details in /home/admispconfig/ispconfig/lib/ correct? Does the MySQL password contain any special characters?
  13. kerl1234

    kerl1234 New Member

    sorry, took me some time to get back to work w/ my server.

    i decided to reinstall ISPConfig just to be sure.
    now i know that the information is correct and regardless of all security considerations the password of the user does not contain any special caracters.

    i also got a modified mysql error:

    instead of 'cannot connect' it says 'access denied for user ''[email protected]" (using password: YES).
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try if you are able to login with the username and password from the file with the 'mysql' command.
  15. kerl1234

    kerl1234 New Member

    no problem there, logs in nicely.

    a question i ran into is, if there could be some sort of loopback problem. what i do is access my server through a vpn-tunnel via an external network, since my home-router isn't configured to loopback. so what i also did, was change the mysql-input in the /home/admispconfig/ispconfig/lib/ from localhost to the my server's url, but no configuration (localhost or url) worked so far.
    of course does the 'localhost'-setting produce the 'cannot connect' error and the 'url'-setting gives the 'permission denied' error
    Last edited: Sep 22, 2009
  16. bastetx

    bastetx New Member

    admin login issue

    After many months /years of running ispconfig 2.2.xx, I had the admin login issue straight out of the blue.
    Odd I thought why?? anyway read your posts and did an investigation myself
    and found the answer was looking straight at me.
    What happened in the xxxx/lib/ file was server setting "localhost" somehow got changed to "LOCALHOST" [AS YOU CAN SEE UPPERCASE]", I dont know how this happened, but I could no longer login.
    changed it back and I can login again.
    Thanks to hard working howtoforge and forum people, your software and help
    is fantastic, got to love linux.

Share This Page