Can't log into ISPConfig Panel

Discussion in 'ISPConfig 3 Priority Support' started by perthsystem, Oct 2, 2014.

  1. perthsystem

    perthsystem New Member

    This is weird...

    My server is setup at I also have numerous websites and users setup there.

    I can log into ISPConfig Panel using the the other domains setup in the control panel but when I try to login using the domain (which is the server domain) it won't let me log in. Either as admin or any other users I have created. By the way I can still access and log into webmail from that base domain.

    No error messages or wrong password notice etc, it just reloads the login page.

    It obviously worked when I first setup ISPConfig, as that's the domain I used to login as admin to create the other sites.

    Anyone with any ideas or sugestions?

  2. srijan

    srijan New Member HowtoForge Supporter

    Does you system recognises the name of your domain

    Try to ping it by both name and IP.

    If it is not pinging then add the manual entry in /etc/hosts file.
  3. perthsystem

    perthsystem New Member

    Yes that all works fine. As I mentioned I get the login page but cant login. When I try to login with 'admin' and my actual password it simply reloads the login page - no errors displayed. If I try to login with 'admin' but using the wrong password it tells me the password is incorrect!
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check the apache error.log for errors. Another possibility is that your browser blocks the session cookie of the ispconfig interface or parts of the javascript. If yu use any plugins that block javascipt and cookies, then please switch them off.
  5. perthsystem

    perthsystem New Member

    Thanks Till,

    I have tried using 4 diferent browsers, same problem.

    It's a brand new install, as per install howto.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please take a look at the apache error.log in /var/log/apache2/ if there are any errors and post the output of:

    mysql --version
  7. perthsystem

    perthsystem New Member

    There are no errors generated in the error.log

    Strange thing is that it just reloads the sign in page, without displaying any errors such as 'incorrect user/password'.

    As I mentioned if I use the URL of one of the sites created it will log in as normal.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats strange as the name or IP that you use to accessthe interface should not make any difference. So only the hostname of the server cant be used and ispconfig is running on port 8080 with https?
  9. perthsystem

    perthsystem New Member

    Yes hostname and hosts all seem correct, ispconfig is running on 8080.
    Very strange :confused:

Share This Page