Can't log into ISPConfig...

Discussion in 'Installation/Configuration' started by EricS, Jun 1, 2006.

  1. EricS

    EricS New Member

    I did the 'Perfect Install' for Fedora Core 5 and all went well...until I entered the IP address of the machine ( just like the example and the server name and domain (server.eswebs.lan). I can't log in using any of the following:

    https://server:81/ (sends me to, strange)

    How can I get logged in? -And- Where are the config files to change the IP and domain of ISPConfig so I can put it on one of my static IPs and my public domain name? Can I do this from the control panel when I get logged in?

    Thanks in advance,
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The installation script has asked you these questions and the script has generated the ISPConfig setu according to your answers.

    If you entered wrong values, you can correct the IP in the file /home/admispconfig/ispconfig/lib/ But a wrong IP does not prevent you from acessing the ISPConfig interface.

    1) Do you have a firewall enabled, that blocks port 81?
    Does your Internet provider blocks port 81?
    Post the output of:

    netstat -tap
  3. ebmar

    ebmar New Member


    I can't access anything else but these ports: 21, 22 and 80 from the outside (did a portscan).

    My output from netstat -tap is:

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost:mysql         *:*                     LISTEN     9891/mysqld
    tcp        0      0 *:81                    *:*                     LISTEN     2250/ispconfig_http
    tcp        0      0 *:ftp                   *:*                     LISTEN     2500/proftpd: (acce
    tcp        0      0 webserver:domain        *:*                     LISTEN     2485/named
    tcp        0      0 localhost:domain        *:*                     LISTEN     2485/named
    tcp        0      0 localhost:953           *:*                     LISTEN     2485/named
    tcp        0      0 *:smtp                  *:*                     LISTEN     2443/master
    tcp6       0      0 *:imaps                 *:*                     LISTEN     6641/couriertcpd
    tcp6       0      0 *:pop3s                 *:*                     LISTEN     6544/couriertcpd
    tcp6       0      0 *:pop3                  *:*                     LISTEN     6481/couriertcpd
    tcp6       0      0 *:imap2                 *:*                     LISTEN     6586/couriertcpd
    tcp6       0      0 *:www                   *:*                     LISTEN     2351/apache2
    tcp6       0      0 *:ssh                   *:*                     LISTEN     4451/sshd
    tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     2485/named
    tcp6       0      0 *:https                 *:*                     LISTEN     2351/apache2
    tcp6       0   2076 webserver:ssh           ::ffff:193.71.163.:1118 ESTABLISHED1179/0
  4. Anim

    Anim New Member

    Put your server in the DMZ and see if you can access it, if so then its a router issue. At least thats how I found my problem.
  5. ebmar

    ebmar New Member

    I cant put it on a dmz, it has a static ip.
    And the server is on a school, and the firewall is 110 km far away.

    The guy who messes up the firewall says the ports I specified is open.
  6. dlikar

    dlikar New Member

    Is your ispconfig_server running? I had a similar problem on SUSE 10. Try /etc/init.d/ispconfig_server restart or whatever does the same on Fedora.

    My server is set to start in runlevel 3. I think that ISPConfig is set by default to start in 2, 3 and 5. So I have removed it from ... (chkconfig --del ispconfig_server) and add it back again (chkconfig --add ispconfig_server). After that everything was OK.

  7. ebmar

    ebmar New Member

    The ISPconfig are running, its running on port 81.
    And the distro is Ubuntu 6.06.
    I've tried restartng the ISPconfig
  8. ebmar

    ebmar New Member

    I've tried to configure apache to run at port 81 and ispconfig to run at port 80.
    Port 81 is blocked. It looks like i've have to kill somebody tomorrow.... :p
  9. falko

    falko Super Moderator Howtoforge Staff

    It was the firewall then... :)

Share This Page