Can't see mysql databases created by phpmyadmin

Discussion in 'General' started by HenryTheEight, Jan 22, 2008.

  1. HenryTheEight

    HenryTheEight New Member


    I am new to ispconfig and linux (Centos), but have found ispconfig a very easy to use application.

    My problem: phpmyadmin seems to be able to list and display the databases
    created by ispconfig e.g. web1_db1 etc. and all works well i.e. the databases
    are listed on the left column on phpmyadmin. However, databases created
    directly by the phpmyadmin control panel e.g. "db_test" does not show up on the please select a database column.

    I only can see the database using mysql commands "show databases;". Is this a bug or do I need to do something to make phpmyadmin recognise the newly created database. Without being able to select the "db_test" database, I won't be able to use the web GUI functions to manipulate db_test.

    Help appreciated.... with thanks

    BTW using phpmyadmin 2.11.4 ispconfig 2.2.19
    Last edited: Jan 22, 2008
  2. Hans

    Hans Moderator Moderator

    No bug

    If you want to display the databases you mention, please remove "test" or "information_schema" from the line:

    $cfg['Servers'][$i]['hide_db'] = '(information_schema|mysql|pmadb|test)';

    within the phpMyAdmin configuration file, which is: /home/admispconfig/ispconfig/web/phpmyadmin/ :)
  3. HenryTheEight

    HenryTheEight New Member

    Thanks for solving this


    Thanks for the tip. Of all the database names to choose from, I had
    to be lucky enough to choose a default hide-db name like "db_test".

    I have since created another database with a more 'unique' database name (i.e. something without the word 'test' or 'mysql' etc.) in it. And ... now all
    is well and working. Now the database with a new name is no longer hidden.
  4. Desp

    Desp Member

    Can't find SQL databases


    I have done an upgrade from ubuntu 11.10 to 12.04 and the problem is that I can see my site up and running while I can't see the database in phpmyadmin. Is there a way to find the old databases or find why I cant see them in phpmyadmin anymore. My website is

    I have also 2 other sites that show a new wordpress installation when I try to open them and they seem can't see the databases created for this sites before.

    So actually I have 2.5 website working out of 5 and can't see any of the databases in phpmyadmin.

    Please help!
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please take a look into the directory /var/lib/mysql/ on your server, there should be a subfolder with the name of the database for each db.
  6. Desp

    Desp Member

    Awesome till, I can see them there thank you alot. Can I just import them to phpmyadmin again? I tried but getting permission denied.
    Last edited: Apr 27, 2012
  7. Desp

    Desp Member

    Your help is much appreciated till, I found the answer.
  8. winsum

    winsum New Member

    i have the same problem.
    when i have updated phpmyadmin, i can't see even a db.
    with the remote access i can manage all db, but nothing with phpmyadmin.

    i don't know what to do with the files listed in /var/lib/mysql/ to showing them in phpmyadmin.

    please help me.
  9. Desp

    Desp Member

    Try to restart MySQL
  10. Desp

    Desp Member

    [SOLVED] Mysql databases not showing after mysql update

    Since this problem happens every now and then, Please try the following:

    Make sure that mysql listning on all interfaces and not only localhost.
    Edit and comment out :
    # bind-address =
    Restart mysql server and try to login to my sql from terminal.
  11. Desp

    Desp Member

    If the above solution don't work or if you get 'Access denied for user 'root'@'localhost' (using password: NO)' error thats because mysql learn that root don't know the password so when you login Don't use a password. Just login using the command
    mysql -u root
    .\q to quit

Share This Page