CDROM not present after initial install v.10.2

Discussion in 'Installation/Configuration' started by radnet, May 17, 2006.

  1. radnet

    radnet New Member

    Somewhat of a newbie, but I'm configuring an IBM Netfinity 5000 to act as a server. Followed Falko Timme's Perfect setup for Mandriva 2006. When I get to installing software, using his list, zip, nmap, ncftp and libxorg-x11-devel all ask for me to put the "Installation Free CD1" or 2, etc in and press enter. I insert them into my CDrom but keep getting the same message. The CD worked fine for the actual installation of the OS.

    I'm assuming that there is something wrong with the /etc/fstab file, or the kernel for loading CDrom support (v 2.6.12-12 currently used). The mount line in the fstab states "/dev/hda ". The problem is, the system isn't locating the cdrom anywhere. I've checked the dmesg and it doesn't show up there anywhere either. It's like it doesn't exist on the system anymore once I've loaded the OS.

    I've searched for hours online looking for a solution and can't seem to find anything. I can urpmi from http and ftp locations without any difficulty, but those four packages (thus far) ask for a CD.

    Any advice? Anyone? Thanks in advance. :confused:
  2. falko

    falko Super Moderator Howtoforge Staff

    Is it a normal CD drive (IDE), or something like USB?
  3. radnet

    radnet New Member

    It's an IDE.

    A question...if the wrong urpmi was installed (I'm thinking I used an i586 version on an PIII - should I have used a x86_64?) would that have anything to do with it? :confused:
  4. falko

    falko Super Moderator Howtoforge Staff

    Don't use x86_64 on a PIII. i586 is correct.
  5. radnet

    radnet New Member

    Alright then, I'm using the right urpmi code. :)

    I opened up the Netfinity 5000 to have a look at how it's all hooked up.

    It is an IDE CDrom hooked to the IDE cable where it is marked "CDROM" and the drive jumper is set to master.

    As I exists for the purpose of installing the OS (which, my mistake is Mandriva 2006 free) but doesn't appear to mount and I'm unable to mount it manually. The drives are on a RAID controller thus the sda partition entries.

    From what limited knowledge I have, the cdrom seems to be associating with the appropriate ide location (1st Primary). Any suggestions what to try next?

    Here's the fstab

    /dev/sda6 / ext3 defaults 1 1
    /dev/sda1 /boot ext3 defaults 1 2
    /dev/hda /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
    none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
    none /proc proc defaults 0 0
    /dev/sda5 swap swap defaults 0 0

    Thanks in advance,

  6. falko

    falko Super Moderator Howtoforge Staff

    This line is wrong. It should be:
    /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
  7. radnet

    radnet New Member

    One line at a time...

    Sorry for the delay in replying, as I've been out of town.

    I've changed the line as you suggested. I now get these errors on boot:

    Mounting local filesystems: mount point auto does not exist
    Mounting other filesystems: mount point auto does not exist

    Plus a third one that I can't catch before it goes to the login prompt.

    when I type in "urpmi zip", I still get

    "Please insert the medium named "Installation Free CD2" on device [/dev/hda]
    Press enter when ready..." and it doesn't load the cd

    If I type "eject", the response is
    "eject: unable to find or open device for: '/dev/cdrom'

    Is there a symbollic link that I need to create or anything telling the system the cdrom exists on hda?

    Next thing to try? :confused:

  8. radnet

    radnet New Member

    One more thing...

    It also keeps coming up with the following whenever I use an urpmi command:

    unable to retrieve pathname for removable medium "Installation Free CD1 (cdrom1)
    unable to retrieve pathname for removable medium "Installation Free CD2 (cdrom2)
    unable to retrieve pathname for removable medium "Installation Free CD3 (cdrom3)

    Maybe this helps narrow down the problem?

  9. falko

    falko Super Moderator Howtoforge Staff

    I'm sorry, but I have no idea what's wrong with your system. :confused: Maybe you should try another distribution...
  10. radnet

    radnet New Member

    Thanks Falko for all the help. I tried 2005LE. Worked fine. So, what the problem was with 2006 is beyone me. I'm now having another issue with postfix, but I'll post that in a new thread.

    Thanks again.

Share This Page