Centos 4.2 Install And Lots Of Questions .

Discussion in 'Installation/Configuration' started by hosting, Feb 8, 2006.

  1. hosting

    hosting New Member

    Ok i was finally after like 5 tries able to get this control panel installed , but when it asked for domain name i put some random domain , and now i have following problems and issues:

    1. The images and all popups that are supposed to popup are all blank and keep trying to connect to that randomdomain.com all the time, resulting in making the control panel utterly useless, i have done this also :

    nano /home/admispconfig/ispconfig/lib/config.inc.php

    and edited the domain in their to the server ip , but still nothing. (Got it working now i think , but how do i setup nameservers as i got only 1 ip.)

    2. The control panel doesnt work in IE at all its all blank page no login page comes up , only works with FF.

    3. VSFTPD is now offline and old users probably got deleted , so how to configure ftp again .

    4. Gives Following Stats under services :
    Web-Server: Offline
    FTP-Server: Online
    SMTP-Server: Online
    POP3-Server: Offline
    BIND-Server: Offline
    mySQL-Server: Online

    I dunno than how come the control panel is working when webserver is offline.

    5. Also , i tried creating a user and domain and ftp account doesnt get created neither does anything else like www/their directory or something, i have yum install httpd.i386 installed , but this cpanel works on old apache and do i need to edit any httpd.conf file to make this thing work , say when i add account it creates their folder somewhere in home etc. the apache built into centos has location of www in /var/www and main site is /var/www/html/ . So how do i create or edit http.conf so that the new users are created and a new seprate folder with their name is made in that html or somewhere on server like with cpanel it makes /home/username, how to get it going? Plus the command /etc/init.d/httpd start or stop doesnt work so to get http online i have to use httpd - k start .

    7.No FTP users get created . Plus vsftpd doesnt work now and i cannot connect to it using ftp client , although service vsftpd start shows vsftpd booted. But ftp client cannot access it.

    So if anyone know how to get the things working properly do let me know.
    Last edited: Feb 8, 2006
  2. hosting

    hosting New Member

    Just removed it all , and now vsftpd works , but any clue as to what is wrong whenever i install it it goes offline ?
  3. falko

    falko Super Moderator Howtoforge Staff

    Wow, lots of questions... First you should have a look into /var/log/ispconfig_install.log and /home/admispconfig/ispconfig/ispconfig.log and look out for errors.

    You mean you want to run your own nameservers? I recommend that you get a second server and then do it like this: http://www.howtoforge.com/forums/showpost.php?p=6292&postcount=4

    That's strange... Which URL did you put in /home/admispconfig/ispconfig/lib/config.inc.php?

    Please post the output of
    netstat -tap
    ISPConfig has its own Apache running on port 81 so that ISPConfig works even if the main Apache is down.

    You don't have to edit httpd.conf at all, it's all done by ISPConfig.

    Please have a look at /etc/passwd to check if your users got created or not.
    Do you have a firewall that prevents accesses to FTP? Please post the output of
    iptables -L
    Did you try both active and passive mode in your email client? What's the exact error message?
  4. hosting

    hosting New Member

    I put myip and do not put www in there , but when it asks for domain say xyz.be i just put my ip. Ok i try installation again also, also it crashes when i use R as the certificate when it asks for rsa key , so have to do D option. And ways i try it installing again now .

    I have sent u iptables -L in ur Email

    I just did reinstall and still same problems . Nothing changed. Even in IE its all blank.

    Also tried to create a user with domain and everything and when i went into ftp login option it said:
    Could not connect as user someuser
    So trying with ftp client is usless cause i can login to other old users that were on vsftpd using the isp panel's ftp tool but not via ftp client like filezilaa.
    Last edited: Feb 8, 2006
  5. hosting

    hosting New Member

    And here is the output for netstat -tap

    [root@localhost vsftpd]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
    tcp        0      0 *:mysql                     *:*                         LISTEN      3882/mysqld
    tcp        0      0 *:sunrpc                    *:*                         LISTEN      2151/portmap
    tcp        0      0 *:656                       *:*                         LISTEN      2170/rpc.statd
    tcp        0      0 *:81                        *:*                         LISTEN      4743/ispconfig_http
    tcp        0      0 someip:ftp          *:*                         LISTEN      4850/ispconfig_tcps
    tcp        0      0 localhost.localdomain:ftp   *:*                         LISTEN      4848/ispconfig_tcps
    tcp        0      0 localhost.localdomain:ipp   *:*                         LISTEN      3550/cupsd
    tcp        0      0 localhost.localdomain:smtp  *:*                         LISTEN      4795/sendmail: acce
    tcp        0      0 someip:81          someip11951ffbea.ss.s:1498 ESTABLISHED 4752/ispconfig_http
    tcp        0      0 someip:81           someip1ffbea.ss.s:1499 ESTABLISHED 4859/ispconfig_http
    tcp        0      0 someip:81           someip.s:1497 TIME_WAIT   -
    tcp        0      0 someip:81           someip1ffbea.ss.s:1495 TIME_WAIT   -
    tcp        0      0 localhost.localdomain:32821 localhost.localdomain:ftp   TIME_WAIT   -
    tcp        0      0 localhost.localdomain:32827 localhost.localdomain:ftp   TIME_WAIT   -
    tcp        0      0 *:ssh                       *:*                         LISTEN      3607/sshd
    tcp        0   2372 ::ffff:someip:ssh   someip.ss.s:1473 ESTABLISHED 4394/0
    [root@localhost vsftpd]#
    Also note that this command doesnt turn vsftpd off ,all it does it turn it on and no off.

    [root@localhost vsftpd]# service vsftpd start
    Starting vsftpd for vsftpd: [ OK ]
    [root@localhost vsftpd]# service vsftpd stop
    Shutting down vsftpd: [FAILED]
    Last edited: Feb 8, 2006
  6. falko

    falko Super Moderator Howtoforge Staff

    If you want to use your IP address, you must leave the hostname empty and enter your IP address as domain during the ISPConfig installation!

    Are you sure you used the correct username (e.g. web1_someuser) and enabled FTP for that web site in ISPConfig?

    vsftpd is run by the ispconfig_tcpserver, therefore you must run
    /etc/init.d/ispconfig_tcpserver start
    to start vsftpd.
  7. hosting

    hosting New Member

    Is this normal :
    [root@localhost ~]# /etc/init.d/ispconfig_tcpserver stop
    Stopping ispconfig_tcpserver
    [root@localhost ~]# /etc/init.d/ispconfig_tcpserver start
    Starting ispconfig_tcpserver
    [root@localhost ~]# Incorrectly built binary which accesses errno or h_errno directly. Needs to be fixed.
    Incorrectly built binary which accesses errno or h_errno directly. Needs to be fixed.
    And where do i enable FTP for that web site in ISPConfig ? I give him hosting plan with ftp checked (if that is what u meant ?)

    And strange my IE doesnt even open the demo site given on ispconfig.org , so what needs to be enabled in IE ? java , active x ? what does it need ?
    Anyways sorted IE problem had to add the site to trusted site, as i got win2k3 on me and IE is kinda too much secured.
    Last edited: Feb 9, 2006
  8. falko

    falko Super Moderator Howtoforge Staff

    The tcpserver seems to be incompatible with your distribution... :(
    I recommend to use ProFTPd instead of vsftpd because then you don't need the tcpserver...

    Yes, that's right.
  9. hosting

    hosting New Member

    Which version of vsftpd does isp need? and isnt proftpd insecure when compared with vsftpd? And can php4.4 be used instead of php5 cause php5 renders hosting usless cause most forums like phpbb, ipb do not work with php5 yet. So is there any package to run install with php4.4 complied and apache2 complied instead of apache 1.3??

    Plus how to access the new users websites? Where do they place files and what url to connect till their domain nameserver propagates for example in cpanel its simples http://ip/~username
    So how does it go with isp? And which version of proftpd if needed be installed , or tell the version of vsftpd it supports.
  10. falko

    falko Super Moderator Howtoforge Staff

    It isn't a matter of vsftpd version. It's just that the tcpserver doesn't work on your system.

    Never had any problems.

    Now you're mixing a few things up. You have your main Apache which serves your web pages. It can be Apache 1.3 or Apache 2 with PHP4 or PHP5, whichever combination you like most.
    And you have the ISPConfig Apache (1.3.x with PHP5) which is running on port 81 and is merely used to serve the ISPConfig web interface. It is totally independent from your main Apache!

    Have a look at chapter 2.2.9 on http://www.ispconfig.org/downloads/manual_en/manual_kunde_en_src.htm#4_2_2.

    You can either wait until the DNS records get propagated, or you change your clients hosts file: http://www.howtoforge.com/forums/showthread.php?t=432

    It doesn't matter. 1.2.10 or something like that.
  11. hosting

    hosting New Member

    Did Proftpd install removed vsftpd totally from system , and now i get this when trying to connect to ftp via isp .

    Could not connect to localhost

    Next >>

    Any clue why?

    Plus under services it says ftp is offline so how do i turn it online ?
    cause this command give this :
    [root@localhost /]# /etc/init.d/ispconfig_tcpserver start
    -bash: /etc/init.d/ispconfig_tcpserver: No such file or directory
  12. falko

    falko Super Moderator Howtoforge Staff

    /etc/init.d/proftpd start
  13. hosting

    hosting New Member

    Got this Error :

    [root@localhost ~]# /etc/init.d/proftpd start
    -bash: /etc/init.d/proftpd: No such file or directory

    So i tried this command :
    [root@localhost ~]# /usr/local/sbin/proftpd start

    Which initially gave error that group nogroup cannot be used it was present in the conf file of proftp so i edited it and made the group as daemon , and used above command (/usr/local/sbin/proftpd start) and it worked and ftp came online but when i created a client with ftp access enable and tried to login i could login isp panel for the user but not via ftp the ftp client kept saying wrong password and isp interface kept saying
    Could not connect as user james
    Next >>
    Also i turned apache on , and when i tried visit my server using http://ip it showed this :

    This IP address is shared. For access to the web site which you look for, enter its address instead of its IP.
    For questions or problems please contact the server administrator.
    and also the bind and pop3 server status in services shows offline .

    So any clue how to fix all these errors? Oh there was no error i think while installing.
  14. falko

    falko Super Moderator Howtoforge Staff

    What exactly did you do to install ProFTPd? Did you use your distribution's ProFTPd package?

    If you create a web site www.example.com in ISPConfig, then you must use www.example.com in your browser's address bar, otherwise you see that Shared-IP page.

    BTW, did you have a look at the "Perfect Setup" tutorials on HowtoForge? They prepare a distribution for the installation of ISPConfig so that ISPConfig works on them out of the box. I suggest that you have a look at these.
  15. hosting

    hosting New Member

    To install Proftpd i did this :

    Downloaded the latest stable source from proftpd.org (http://www.proftpd.org) and extracted. Then ran:
        # ./configure --with-modules=mod_sql:mod_sql_mysql:mod_quotatab:mod_quotatab_sql \
        --with-includes=/usr/include/mysql --with-libraries=/usr/lib/mysql \
        --sysconfdir=/etc --localstatedir=/var
        # make
        # make install.
    And in the isp config i had put ip instead of domain , so shared ip i dunno understand u think putting more ip on server would solve it ?

    And what is the link to perfect installation ?

    But what about bind not working ? i tried using command the command and end up getting this error :

    [root@localhost init.d]# ./named start
    Starting named: /etc/named.conf:5: change directory to '/var/named/chroot/var/named' failed: file not found
    /etc/named.conf:5: parsing failed
    Feb 10 18:43:16.348 starting BIND 9.2.4 -g
    Feb 10 18:43:16.349 using 2 CPUs
    Feb 10 18:43:16.352 loading configuration from '/etc/named.conf'
    Feb 10 18:43:16.352 listening on IPv4 interface lo,
    Feb 10 18:43:16.353 listening on IPv4 interface eth0,
    Feb 10 18:43:16.367 command channel listening on
    Feb 10 18:43:16.367 command channel listening on ::1#953
    Feb 10 18:43:16.367 ignoring config file logging statement due to -g option
    Feb 10 18:43:16.367 couldn't open pid file '/var/named/chroot/var/run/named/named.pid': Permission denied
    Feb 10 18:43:16.367 exiting (due to early fatal error)
    Error in configuration file /etc/named.conf :              [FAILED]
    [root@localhost init.d]#
    Ok i removed bind from system and reinstalled it using yum install bind-chroot.i386 and now when i issue the command it says :
    [root@localhost init.d]# ./named start
    Starting named: [ OK ]
    [root@localhost init.d]#

    And shows online in isp. services menu as online, but pop3 still showing offline and ftp cannot be used . Do u have msn or yahoo falko?
    Last edited: Feb 11, 2006
  16. falko

    falko Super Moderator Howtoforge Staff

    No, the amount of IP addresses has nothing to do with it. The Shared-IP page means that you must use the FQDN to access the web site, not the IP address.
    If you host more than one web site on an IP address and just type in the IP address in your browser's address bar, how is Apache supposed to know which web site you want to see?

    Fedora Core 3: http://www.howtoforge.com/perfect_setup_fedora_core_3
    Fedora Core 4: http://www.howtoforge.com/perfect_setup_fedora_core_4

    No, I don't have any instant messengers.
  17. hosting

    hosting New Member

    Ok tried installing using that perfect install , but i didnt install fedora cause i dont want to pay my dc to do reload of os just for a control panel.

    But when it finishes install it says these things and httpd it cannot start so when i try to start it fails :

    Restarting some services...
    httpd not running, trying to start
    Shutting down sendmail: [ OK ]
    Shutting down sm-client: [ OK ]
    Starting sendmail: [ OK ]
    Starting sm-client: [ OK ]
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

    [root@localhost install_ispconfig]# service httpd start
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting httpd: [FAILED]
    [root@localhost install_ispconfig]#

    but when i try httpd -k start it turns apache on .
  18. hosting

    hosting New Member

    But u didnt tell me if i installed proftpd properly or not cause i cannot still login to ftp either using client or using isp itself , just keeps giving this error.
    Response:	220 ProFTPD 1.2.10 Server (ProFTPD Default Installation) [someip]
    Command:	USER james
    Response:	331 Password required for james.
    Command:	PASS ********
    Response:	530 Login incorrect.
    Error:	Unable to connect!
    So any clue which file to edit or chmod or something to make ftp work atleast forget www , just ftp would be good enough for me . Under services these are the status of various services :

    I can login to ftp using my older user account that i created mannually before doing the installation. But isp cannot create any user at all.
  19. hosting

    hosting New Member

    Just an update WWW works properly now as i can access sites using domain name :) . too bad no nameserver like ns1.mysite.com and ns2.mysite.com can be assigned , cause i dunno where to enter them . And cannot login to ftp maybe need to mannually for each user make ftp ?
  20. hosting

    hosting New Member

    Hey here is the ftp output from command [root@localhost ~]# nano /etc/proftpd_ispconfig.conf

    # ISPConfig proftpd Configuration File
    #         Version 1.0
    <VirtualHost someip>
            DefaultRoot             ~
            AllowOverwrite          on
            Umask                   002

    And output from command [root@localhost ~]# nano /etc/proftpd.conf

    # This is a basic ProFTPD configuration file (rename it to
    # 'proftpd.conf' for actual use.  It establishes a single server
    # and a single anonymous login.  It assumes that you have a user/group
    # "nobody" and "ftp" for normal operation and anon.
    ServerName                      "ProFTPD Default Installation"
    ServerType                      standalone
    DefaultServer                   on
    # Port 21 is the standard FTP port.
    Port                            21
    # Umask 022 is a good standard umask to prevent new dirs and files
    # from being group and world writable.
    Umask                           022
    # To prevent DoS attacks, set the maximum number of child processes
    # to 30.  If you need to allow more than 30 concurrent connections
    # at once, simply increase this value.  Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd).
    MaxInstances                    30
    # Set the user and group under which the server will run.
    User                            ftp
    Group                           ftp
    # To cause every FTP user to be "jailed" (chrooted) into their home
    # directory, uncomment this line.
    DefaultRoot ~
    # Normally, we want files to be overwriteable.
    AllowOverwrite          on
    # Bar use of SITE CHMOD by default
    <Limit SITE_CHMOD>
    # A basic anonymous configuration, no upload directories.  If you do not
    # want anonymous users, simply delete this entire <Anonymous> section.
    <Anonymous ~ftp>
      User                          ftp
      Group                         ftp
      # We want clients to be able to login with "anonymous" as well as "ftp"
      UserAlias                     anonymous ftp
      # Limit the maximum number of anonymous logins
      MaxClients                    10
      # We want 'welcome.msg' displayed at login, and '.message' displayed
      # in each newly chdired directory.
      DisplayLogin                  welcome.msg
      DisplayFirstChdir             .message
      # Limit WRITE everywhere in the anonymous chroot
      <Limit WRITE>
    Include /etc/proftpd_ispconfig.conf

Share This Page