CGI Downloading

Discussion in 'Installation/Configuration' started by E.L. Hibee, Jul 14, 2006.

  1. E.L. Hibee

    E.L. Hibee New Member


    I have attepted to install a cgi photo album on my site (setup on my suse 10 server) however whenever I try to go to that album IE attempts to download the cgi file.

    If I leave out the index.cgi part I get a 403 error.

    I have tried with other test cgi files and the same thing happens

    I am not very clued up on this so any help as always is appreciated.

    Last edited: Jul 14, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you post your vhost configuration here?
    Do you have something similar to

    ScriptAlias  /cgi-bin/ /path/to/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    in it?
    Also have a look here:
  3. E.L. Hibee

    E.L. Hibee New Member

    Is it the Vhosts_ispconfig.conf file you are talking about?

    If so the the Vhost section for this site is:

    also after reading the link you supplied I added

    This did not solve the issue, but now does mean I can allow cgi in any folder which is what I was after as well, so thanks for that it helped a bit.

    I have also ran:

    Is my path to perl wrong?

    I have tried searching through the web and forums for days now but cannot see anything, maybe I am just searching for the wrong thing

    Last edited: Jul 19, 2006
  4. falko

    falko Super Moderator ISPConfig Developer

    Ah, you're using ISPConfig...

    You must put your CGI scripts into /home/www/web2/cgi-bin/ and make them executable, then it should work out of the box.

    If you see this: ^M at the end of your lines it means you saved the file with Windows linebreaks, not with Unix linebreaks. Save the file with Unix linebreaks (some editors on Windows allow you to do this) and try again.

Share This Page