Change IP Address - CentOS 4.4 / ISPConfig

Discussion in 'Installation/Configuration' started by tobz, Mar 26, 2007.

  1. tobz

    tobz New Member


    I recently placed a CentOS server at a datacenter. I tested my installation on my private network, and everything worked well. When I changed the IP address to one that conforms to my network at the datacenter (using system-network-config), everything worked well. When I rebooted, it changed back to my old IP address (that I configured on install). I thought system-config-network was all I needed to do.

    I figured a config file or init script somewhere must be changing it back. So, I did a 'find' to search my configs, and anything with the old IP address, I replaced with the new one. I rebooted, and the IP address changed back again. I became confused and frustrated, so I removed my server from the datacenter for another rebuild.

    This time I followed the Perfect CentOS 4.4 how-to, and installed ISPConfig when I was done. Everything works well, on my private network. I am really happy with ISPConfig. Now it is time to place my server into the datacenter, and I don't want to repeat my previous error.

    Has anyone done this before and could tell me what I need to do to avoid this problem? There must be some changes besides the system-config-network that I need to make.

    Thank you,

  2. falko

    falko Super Moderator ISPConfig Developer

Share This Page