Choose different PHP version = no effect [solved]

Discussion in 'Installation/Configuration' started by instagib, Mar 22, 2016.

  1. instagib

    instagib New Member

    Last edited: Mar 28, 2016
    Elly Jhon likes this.
  2. Well-Known Member HowtoForge Supporter

  3. instagib

    instagib New Member

    I have already one site with php7. I changed it before I upgraded ISPConfig. Only that site works with php7, no other sites.
    By the way im using fastcgi not php-fpm.
    Last edited: Mar 24, 2016
    Elly Jhon likes this.
  4. Well-Known Member HowtoForge Supporter

    Have you set ISPConfig logging level to debug and checked if there's an issue?
    Did it create the php5 fpm config file but did not change the vhost? Is there an .err file for that vhost after switching php version?
  5. instagib

    instagib New Member

    Edit: Problem solved. I had to uninstall systemd which I had previously installed. Thanks for your assistance.

    Link to .vhost:
    Link to .vhost.err:

    Output from ispconfig.log:
    28.03.2016-13:57 - WARNING - Apache did not restart after the configuration change for website Reverting the configuration. Saved non-working config as /etc/apache2/sites-available/
    28.03.2016-13:57 - WARNING - Reason for Apache restart failure: Failed to get D-Bus connection: No connection to service manager.

    How can I make it work with init.d instead of systemd?
    My server is running Debian 7.
    Last edited: Mar 31, 2016
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    ispconfig detects the init system automatically, no need for any reconfiguration. if systemd is not present, then the init scripts are used automatically.

    The lines that you posted from the log show that the init system is working nicely, the issue is just that you either added some incompatible config in the apach directives field of this website or that one of the standard apache modules from perfect server tutorial is missing and therefor apache does not understand the config so that ispconfig has to revert to the last working config.

    Remove the .err file ending from the file and restart apache, you will then see the error message that apache complains about on the shell.
  7. Well-Known Member HowtoForge Supporter

    Actually the Failed to get D-Bus connection is because it still tries to use system - you might want to check at your init system files.
    Did you --purge remove systemd ? Did you try reconfigureing / reinstalling $apt-get install sysvinit-core sysvinit-utils ?
    Check your /etc/inittab, if unsure make a backup and cp /usr/share/sysvinit/inittab /etc/inittab
  8. instagib

    instagib New Member

    Yes, I had previously installed systemd, and just left it there without thinking. But systemd doesn't work on Debian 7 (according to google). The solution was to uninstall it.

Share This Page