compile custom php for ubuntu 16.04

Discussion in 'HOWTO-Related Questions' started by tommsen, Dec 13, 2016.

  1. tommsen

    tommsen New Member

    i followed the perfect server howto for ubuntu 16.04 and it worked fine so far. Now i want to compile different php versions (5.5, 5.6).
    I tried to follow this howto ( which i used successfully in the past.
    First error i get is:
    root@myserver /etc/apt # apt-get build-dep php5
    Reading package lists... Done
    E: Unable to find a source package for php5​

    ok, so i enabled all deb-src entries in /apt/sources.list and did apt-get update. But that doesnt show updating src-entries. Still unable to find the source package for php5. What am i doing wrong? Is it possible to do this build-dep for php5, which doesnt come with ubuntu 16.04 (php 7)?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There should be a source package for php7.0 instead of the php5 one.
  3. tommsen

    tommsen New Member

    i tried that too, no luck:
    root@myserver ~ # apt-get build-dep php7
    Reading package lists... Done
    E: Unable to find a source package for php7
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    php7.0 and not php7
  5. tommsen

    tommsen New Member

    oh yes, stupid me!:(
    thanks a lot for the pointer!
  6. tommsen

    tommsen New Member

    compiling/installing working nice so far, but i get errors when making apc. Any ideas on this?
    root@myserver /opt/php-5.5.38/etc # pecl -C ./pear.conf install apc
    Makefile:188: recipe for target 'apc_compile.lo' failed
    make: *** [apc_compile.lo] Error 1
    ERROR: `make' failed
  7. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    cd /opt/php-5.5.38/
    bin/pecl -C ./pear.conf install XXX
    vi lib/php.ini
  8. tommsen

    tommsen New Member

    sorry i dont get it.
    pear.conf is in /opt/php-5.5.38/etc not in /opt/php-5.5.38 so bin/pecl -C ./pear.conf install XXX doesnt work after cd /opt/php-5.5.38.

    root@myserver /opt/php-5.5.38 # pecl -C ./pear.conf install apc
    downloading APC-3.1.13.tgz ...
    Starting to download APC-3.1.13.tgz (171,591 bytes)
    .....................................done: 171,591 bytes
    55 source files, building
    running: phpize
    sh: phpize: command not found
    ERROR: `phpize' failed

    I assume the vi lib/php.ini is for adding the extension after successful install?
  9. jamby

    jamby New Member

    I installed my vps php7 and multiple config php 5.6.28 and 5.4.45. All working - only php5.4.45 memchached not works. I using sourceforge docs for multiple php ispconfig 3.1. Main system is ubuntu 16.04.
  10. sukk741

    sukk741 New Member

    Compile / install the good work so far. But I get an error when APC has any idea about this?

Share This Page