Compile Kernel 2.6 under Debian Sarge

Discussion in 'Kernel Questions' started by falko, Apr 21, 2005.

  1. falko

    falko Super Moderator Howtoforge Staff

    /etc/fstab and /boot/grub/menu.lst look ok...
  2. Flip

    Flip New Member

    Ok I thinks thats ok then. You don't have any onther idea's?:confused:
  3. falko

    falko Super Moderator Howtoforge Staff

    Not really...
  4. Flip

    Flip New Member

    OK, thats not so nice than. Could the problem been solved if I give you acces to my server? Hopefully you find something;(
  5. falko

    falko Super Moderator Howtoforge Staff

    This would be professional support then, and I'd have to charge you for that. If you're interested, please PM me.
  6. Flip

    Flip New Member

    No, than I'm not interested. Thanks anyway
  7. Layn

    Layn New Member

    Hello Flip,
    Have you add support for your file system? and ide support, i think you you have a problem with something about disc (ide, filesystem...)
    If you add this support as module, then you can to put this modules into the /etc/mkinitrd/modules.

  8. Flip

    Flip New Member

    I don't know exactly
  9. falko

    falko Super Moderator Howtoforge Staff

    You can check the kernel config file in /boot to see what is enabled and what isn't.
  10. Flip

    Flip New Member

  11. falko

    falko Super Moderator Howtoforge Staff

    And which file system do you use? Please post your /etc/fstab here.
  12. Flip

    Flip New Member

  13. falko

    falko Super Moderator Howtoforge Staff

    So you're using ext3, and ext3 is enabled as a module in your kernel.
    Did you create a ramdisk or put the ext3 driver into /etc/mkinitrd/modules, as Layn suggested?
  14. Wraithfire

    Wraithfire New Member

    Ok so I've been following this post now for about 5 days or so i guess. I seem to be having the exact same problem that Flip is. Following your initial instructions back at top, i finished with the same error message as Flip and i noticed as you pointed out falko that the initrd line was missing from /boot/grub/menu.lst So after editing that, i rebooted and got an error of unable to mount root unknown block (3,1) instead of (0,0). So it seems that maybe Layn is correct about the ext3 driver since i also enabled ext3 support in the make menuconfig. So how do I go about adding the ext3 driver into /etc/mkinitrd/modules file? Also, if i followed your instructions exactly falko, would that have created a ramdisk?
  15. falko

    falko Super Moderator Howtoforge Staff

    Can you post the output of
    locate ext | grep -i "/lib"

    Yes, that's right.
  16. Wraithfire

    Wraithfire New Member

    OMFG I am such a noob :(
    I got the system to boot up fine following your directions, I added ext3 to /etc/mkinitrd/modules. I had noticed from one of your earlier posts that the initrd line was missing from /boot/grub/menu.lst for Debian GNU/Linux, kernel 2.6.16 Default. So what i was doing was adding initrd /boot/initrd.img-2.6.16 to that section for Default and Default (Recovery). Then I just now noticed that /boot/initrd.img-2.6.16 was already on Debian GNU/Linux, kernel 2.6.16 a little bit farther down in the file. The difference between the 2 is that the second is not (Default), and they are listed the same way in the boot menu. So i left the initrd line out of the (Default) section, selected that at boot up menu and it loaded up great, version 2.6.16 So I guess I was pointing grub to a different kernel image then i should have?
  17. sbovisjb1

    sbovisjb1 Member HowtoForge Supporter


    Yes i quite agree...
    also if you want to install custom dependincies, just create files(in the apt-get shell directory)that describes the location and the keys of updates... that way when ever you want to update anything you can have the files you want.
  18. chief_officer

    chief_officer New Member


    I tried to update my kernel to yesterday. I have downloaded the kernel to /usr/src and untar'ed it and then finished the menuconfig. When I typed

    /usr/src/linux. clean

    I get the following error message:

    make:*** No rule to make target `kpkg-clean'. Stop.

    Meantime, when I type

    /usr/src/linux. fakeroot make-kpkg --initrd --revision=custom.1.0 kernel-image-

    I get the following error message:

    Error: Unknown target kernel-image- use --targets to display help on valid targets
    I am following your tutorials from the following to update my kernel:

    and also from official debian site:

    I did a fresh install of Debian Sarge on my Toshiba Satellite Pro 6100 [didn't do dist-upgrade]. And yes, I have never compiled a kernel before.

  19. falko

    falko Super Moderator Howtoforge Staff

  20. coolvik

    coolvik New Member


    thanks for the guide!

    I've downloaded the kernel and made the configuration.

    Everything seems to work fine until I boot the system with the new kernel. It hangs almost at the end.

    I've a Dual Xenon EM64t system. And thats why I want to use this later kernel version, becouse the regualr 2.6.8 em64t smp kernels don't work either.

    Anyone with experiences in this?

Share This Page