Computer hangs during compilation

Discussion in 'Installation/Configuration' started by vitoco, Feb 20, 2006.

  1. vitoco

    vitoco New Member

    My PC dies during while running the ./setup ... no keyboard, mouse or network response :mad:

    I tried twice, and both times the process stopped just after the following:
    making all in apps...
    make[1]: Entering directory `/root/install_ispconfig/compile_aps/openssl-0.9.8/apps'
    gcc -DMONOLITH -I.. -I../include  -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -mcpu=pentium -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS -DOPENSSL_IA32_SSE2 -DSHA1_ASM -DMD5_ASM -DRMD160_ASM -DAES_ASM   -c -o verify.o verify.c
    gcc -DMONOLITH -I.. -I../include  -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -mcpu=pentium -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS -DOPENSSL_IA32_SSE2 -DSHA1_ASM -DMD5_ASM -DRMD160_ASM -DAES_ASM   -c -o asn1pars.o asn1pars.c
    gcc -DMONOLITH -I.. -I../include  -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -mcpu=pentium -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS -DOPENSSL_IA32_SSE2 -DSHA1_ASM -DMD5_ASM -DRMD160_ASM -DAES_ASM   -c -o req.o req.c
    My box is a Pentium 4 with an old video card (I don't want a graphical desktop on this server), running a fresh CentOS 4.2 ServerCD installed using notes for 4.1 and 4.2.

    Hints? :confused:

    Thanks... ++Vitoco
    Last edited: Feb 20, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Compiling the packages makes a heavy load on your PC. Have you checked if your cooling system is ok and your processor does not get to warm?
  3. falko

    falko Super Moderator Howtoforge Staff

    Can you try this:
    cd /tmp
    tar xvfz openssl-0.9.8.tar.gz
    cd openssl-0.9.8
    make install
    Does that work?
  4. vitoco

    vitoco New Member

    Died exactly at the same point without an error message: gcc req.c

    I could hear how the processor's fan changed it's speed during the compilation, so I'll try opening my box and forcing an overcool using an external fan, as till suggested...

  5. falko

    falko Super Moderator Howtoforge Staff

    Strange... Normally OpenSSL doesn't make any problems at all when you compile it...
  6. vitoco

    vitoco New Member

    Solved. As Till suggested, it was related with the cooling system. There is something in req.c that generates too much heat in my processor.

    Then failed with the "ERROR: The URL is not reachable!" problem. I had to restart all again unsuccessfully. It seems that it is also required to remove the ispconfig prior to retry ./setup ... BTW, is it possible to retry only the last part of the setup?

    Now that I it is working OK, I'll have to learn more about DNS setup and how to config ISPConfig behind an ADSL modem with NAT.

    Thanks again... ++Vitoco
  7. falko

    falko Super Moderator Howtoforge Staff

    Yes, you must remove ISPConfig after a failed installation attempt.

    No, that doesn't work.

Share This Page