Courier IMAP / POP3 error when re-creating ssl certificate

Discussion in 'Server Operation' started by Debian2009, Apr 21, 2009.

  1. Debian2009

    Debian2009 New Member

    I followed "The Perfect Server -Debian Lenny (Debia 5.0) [ISPConfig 2]" up to item 13: Courier IMAP / POP3.
    When I run 'mkimapdcert', the following error message occurred.

    When I restart the server, it seems there is no error during boot up.

    Please advise if the error message will affect the functionality of the courier server.


    Attached Files:

  2. falko

    falko Super Moderator ISPConfig Developer

    You can ignore the error message.
  3. Debian2009

    Debian2009 New Member

    Thanks Falko.

    I found that /usr/lib/courier/imapd.pem was softlink to /etc/courier/imapd.pem.
    (same for pop3d.pem)

    I tried the following:

    rm both imapd.pem files, then run 'mkimapdcert'. Now error message. imapd.pem was generated in /usr/lib/courier/. Then I mv the pem file to /etc/courier/ and re-create the softlink.

    Are these steps OK.

    I am setting up this mail server for internal LAN use (not open to the internet). Is setting up courier SSL server of any use?

    Whenever I connect to the mail server using an email client (outlook, thunderbird), a message pop up saying that the certificate is not from a trusted source. How can I let the email client know that the certificate can be trusted and avoid the pop up message?

    Thanks in advance.
  4. falko

    falko Super Moderator ISPConfig Developer

    I think so.

    I don't think you need SSL inside your LAN (unless you don't trust the users in your LAN).

    You'd have to buy a certificate from a trusted CA such as Verisign or InstantSSL.
  5. Debian2009

    Debian2009 New Member

    Thanks Falko


    Thanks so much for clearing things up. :) :D

Share This Page