Courier Issues

Discussion in 'Installation/Configuration' started by gnosti, Aug 28, 2009.

  1. gnosti

    gnosti New Member

    Courier Issues [SOLVED]

    Okay so I was messing around in things that I shouldn't have been and now I've smegged something.

    I decided I was going to setup dns so that my ispconfig could be the authoritative nameserver. I knew that mydns was installed but couldn't find the db for it so I decided to create one and changed the mydns.conf file to reflect the new db. shortly thereafter I discovered that the ispconfig db had all of this stuff in it. Well I had already erased the password that was in the mydns.conf for the ispconfigdb so I (for some reason) decided to change the password in the ispconfig db. As you can probably guess this completely broke everything.

    I went in and fixed everything and replaced the old password in every conf file that I could find that referenced it to the new password.

    I have everything working except for courier apps. pop, imap.

    I replaced the password in /etc/courier/authmysqlrc however this didn't seem to help.

    When I attempt to login to squirrelmail it gives me
    I check the contents of /var/log/mail.err and have

    The same thing occurs when attempting with pop,

    I telnet to 143 without issue

    and mutt imap://localhost/ seems to respond without issue as well.

    I'm almost positive that this has to do with some config somewhere that still has the old password but I'm not at all sure which one and I am looking for pointers, because at this point I'm thoroughly defeated.

    Also I've verified the password is correct in all the files that I've changed including /etc/courier/authmysqlrc

    Any ideas would be most appreciable.

    Thanks in advance.
    Last edited: Aug 29, 2009
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The mysql login details are not correct or you did not restart mysql.

    Test the details that you entered in the /etc/courier/authmysqlrc with:

    mysql -h localhost -u ispconfig
  3. gnosti

    gnosti New Member

    Thanks for the quick reply! :)

    the password was pasted directly from authmysqlrc info

    which i will paste here (minus the pw of course) in case there is a typo that I'm just not seeing from looking at the thing for so long.

    I greatly appreciate the help.
  4. gnosti

    gnosti New Member

    Okay, so I've now created a new dbuser named ispdbuser and granted all privileges for the ispconfig db and am still getting the same behavior from courier-authdaemond.

    I have quadruple checked the password in the config and have gone through the same trouble shooting steps over and over and am at a complete and total loss now. If anybody has any ideas I would be most appreciative.

    Thanks in advance.
  5. gnosti

    gnosti New Member

    Courier Issues [SOLVED]

    Okay I finally got it resolved. I made backups of my courier configs and killed all courier services. I then purged all courier services and re-installed fresh, made the appropriate changes to the configs and specified


    restarted the services and WALLAH! everything is up and running as it should be.

Share This Page