Creating Mysql database within remote framework

Discussion in 'Installation/Configuration' started by gauthier, Oct 14, 2007.

  1. gauthier

    gauthier New Member


    I am using remote framework to create new sites. I also need to create one database for each sites.

    To create new sites, I use the soapclient call function with parameters:

    I see in ISPconfig the site is created with Mysql enabled and Number of Database=1. Soapclient debug does not show any error during this step:
    The problem is if I try to create the needed database (using remote framework) I have the error message: "HTTP Error: no data present after HTTP headers".


    In ISPconfig I can see database have been created but phpMyadmin does not allow access (user or password error). I tried to change password using ISPconfig but it does not work. I removed database in ISPconfig, create new one... ok.

    I also tried to UPDATE site with 'web_mysql' => 1 and 'web_mysql_anzahl_dbs' => 5 but it does not solve the problem. Maybe I am doing something wrong but it seems mysql is not actualy enabled when site is created.

    Thanks if someone can help me.
    Last edited: Oct 14, 2007
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This looks like a bug in the remoting framework. I added it to the bugtracker.

Share This Page