cron task not running

Discussion in 'Installation/Configuration' started by Chag, Jul 27, 2021.

  1. Chag

    Chag New Member

    I have a cron task not running. I first thought there was something wrong with my command. So I made a simple one in the ispconfig's cron manager.
    * * * * * web1 /var/www/
    'log output' and 'active' are checked
    I tried with
    but same result.
    my script is really simple :
    echo `date` >> /var/www/
    I tried differents rights up to 777 on the script and it's is owned by user web1
    I can see the task in /var/log/cron/log
    Jul 27 22:10:01 srv1 CRON[25552]: (web1) CMD (/var/www/ >>/private/cron.log 2>>/private/cron_error.log
    but no file is created. neither cron.test, nor logs in private
    If I try to run that task manually :
    sudo -u web1 /var/www/ >>/private/cron.log 2>>/private/cron_error.log
    everything is created but log files appear in /private, not in /var/www/ as I would expect. I'm runnig out of ideas. Am I missing something obvious ?
  2. Chag

    Chag New Member

    figured it out.
    Had to set full cron in limits of user account. Sorry for the noise
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    You can use chrooted cron as well, but in case of a chrooted cron, your script would have to be:

    echo `date` >> /web/cron.test

Share This Page