cube panel

Discussion in 'Installation/Configuration' started by DataVampire, May 1, 2006.

  1. DataVampire

    DataVampire New Member

    has anyone installed cube panel on fedora core 3, im having a rite nightmare trying to install it, i have basicly done a basic install of fedora core 3 then followed the instructions via the linux install manual, using yum install mysql ect ect, then i have done the command of unshar filename, wich it doesnt mention anywhere in the manual i would like to add, it then goes to creat a lock directory, wich takes ages, it then comes up with the agreement you have to obviously select y, to procede, i have done this, it then hangs.
    Last login: Mon May 1 17:35:50 2006 from
    [root@localhost ~]# ls
    anaconda-ks.cfg cubepanel_fc3_trial-2_0.shar install.log install.log.syslog
    [root@localhost ~]# unshar cubepanel_fc3_trial-2_0.shar
    x - creating lock directory


    You are going to install Cube Panel.

    Cube Panel is composed of software and documentation protected by
    Intellectual Property rights as well as other rights favouring
    Biztology and its suppliers.

    You may only install the Cube Panel if you accept the terms and
    conditions of the Cube Panel license agreement detailed in the

    The use of Cube Panel is limited to those activities authorised in
    the cited terms and conditions, therefore any other activity that is
    not expressly permitted requires Biztology´s written authorization.
    Without limiting what has been previously set out, the copying and/or
    reproduction of Cube Panel is strictly prohibited on any other
    unauthorised server and/or location, and/or its reproduction or

    Cube Panel´s guarantees are those as established in the terms and
    conditions of the license agreement. Biztology does not assume any
    responsibility in terms of performance, functions or utility beyond
    what is declared in the stated license agreement.

    ¿Do you agree with license terms and conditions? (y/N):
    this is installing the trial, i have bought and tried to install the retail version, with the same results, can anyone help me please.
    thankyou in advance
  2. falko

    falko Super Moderator Howtoforge Staff

    If I understand the installation manual right ( ), you don't have to unshar cubepanel_fc3_trial-2_0.shar. Instead, you must execute that file:
    cd /directory/where/you/downloaded/cubepanel
    You might have to make cubepanel_fc3_trial-2_0.shar executable before:
    chmod 755 cubepanel_fc3_trial-2_0.shar
  3. DataVampire

    DataVampire New Member

    thankyou for your fast response i tried that but got the same responce. now two weeks into it, still the same. i am fealing like i have wasted my money!!!!!
  4. falko

    falko Super Moderator Howtoforge Staff

    Do you get any error messages? Did you make the file executable?
  5. DataVampire

    DataVampire New Member

    thank you for the response. after many hours of testing and trying different things i have finaly sorted it, it apears you need to have the core systems up and running. ie httpd, mysql,mailman ect ect, jsut a shame it doesnt mention this at all in the instalation manual.
    the next probelm i have got is trying to configure it to use my domain name i have bought.
    the sarga continues.............................
  6. webcore

    webcore New Member

    to execute the .shar file do:

    sh filename.shar

    Good luck
  7. DataVampire

    DataVampire New Member

    thx for replying i have odne that part and got it installed the only prob i have involes the use of my external ip instead on the internal lan ip, i have got a response of the tech support they say i need to modify the database and change a few ebtries. this is what they said to do.
    A way round that DNS issue, would be modifying the DNS_DEFAULT_RECORDS table of CUBE DB with your public IP, so domains DNS entries are created with your public IP. If you decide proceeding with that, under your own responsability, we recommend you backing up the CUBE DB before. The values that you need to replace with your public IP would be $ip, $ipPrincipal and $ipPanel only.
    the only prob is this how on earth do i edit those entries, im not usre how to acses the database, is a feibt ebd fir nysql installed as standard as i cannot see it anywhere ??.
    if anyone can help i would be greatfull
    thank you again for all your ideas and support
  8. webcore

    webcore New Member

    they can easily be edit from a console.

    # mysql -u root -p
    Enter password: (type your root mysql password)
    mysql> use CUBE;
    mysql> UPDATE DNS_DEFAULT_RECORDS SET VALUE = 'your_public_ip' WHERE VALUE ='$ip' OR VALUE ='$ipPanel' OR VALUE ='$ipPrincipal';

    Before you execute that code change "your_public_ip" string for you real public IP. "VALUE = 'your_public_ip' into "VALUE = 'x.x.x.x'.
  9. DataVampire

    DataVampire New Member

    not sure about this, i dont want to mss it upin the email i resieved it mentioned only altering the 3 fields mentioned above, its taken me this long to get the controle panel instaled in the first place.if anyone could walk me thru it would be great i can provide my msn addy from ther ei can provide details of my server, thx ever so much for your help so far in this matter, hopfully i will be able to get it sorted soon, its been a very long project.
  10. webcore

    webcore New Member

    If you are not sure about executing a SQL command, I would go for reseller or shared hosting. There are many good deals these days.

    It will save you a headache
    Last edited: May 12, 2006
  11. DataVampire

    DataVampire New Member

    lol thx for info i already got my own server thx, this is just for my home server at home, to test sites ect before i upload them to my main server. btw that command did nothing but alter dns, it didnt alter the main ip, wich is what i wanted.
    but thx anyhow
  12. webcore

    webcore New Member

    That is everything that it is sopossed to do. Now your domains will bind to your public IP. Restart Dns service and check which IP your domains resolve to. If they resolve to your router IP, and your router is redirecting correctly to your web, mail, etc, servers, i think there is no need to change your servers IP as it won't be visible outside.
  13. Cemtex

    Cemtex New Member

    Main ip


    Can anyone help to change my main panel ip in the database, as due to a typo when setting the server up i set static ip to but it was supposed to be So now the cubepanel main ip is set to

    thanks :)
  14. falko

    falko Super Moderator Howtoforge Staff

    Do you have phpMyAdmin installed? Then you can change the IP address with phpMyAdmin.

Share This Page