Deb Wheezy-Jessie upgrade.. dpkg --configure -a hangs

Discussion in 'ISPConfig 3 Priority Support' started by blackfox123, Jan 21, 2016.

  1. blackfox123

    blackfox123 Member

    I'm having weird problems with my dist-upgrade.

    dpkg --configure -a
    seems to hang all the time, i cannot start or stop any services.. and to gain access to the system i've had to start sshd in the rc.d script manually.

    It seems nothing will really start/stop.. I've also tried apt-get install -f with no avail.
  2. ressel

    ressel Member

    Do you have a backup?
  3. blackfox123

    blackfox123 Member

    I can see in systemctl that the dbus.service didnt start, and systemd-modules-load.service didnt either..
    You think i could just delete the lock file for dpkg, remove the packages according to this:
    then carry on again?

    I have a backup in the system.. although i'm not 100% on how to restore, or even what to restore..

    I'm also in DK btw ;)
  4. blackfox123

    blackfox123 Member

    I've gone ahead and solved this with a mixture of restoring some backups.. deleting systemd and rebooting.. seems to have worked. upgrading 1 of 7 servers to jessie.. the first one went like hell.. :( must be an easier way.
  5. webguyz

    webguyz Active Member HowtoForge Supporter

    How did you delete systemd? Was that the only thing you did before upgrading?

  6. blackfox123

    blackfox123 Member

  7. webguyz

    webguyz Active Member HowtoForge Supporter

  8. till

    till Super Moderator Staff Member ISPConfig Developer

    I upgraded several servers from deb 7 to deb 8 already without having any issues yet, they were all based more or less on the perfect server setup. I used:

    Then a ispconfig update with reconfigure services so that all config files get updated to versions that match the newly installed software and then login to ispconfig and run Tools > Resync on the websites to update the apache vhost files to apache 2.4 syntax.

Share This Page