Debian 5.0 -ISPConfig 3 install - Unable to connect to mysql server

Discussion in 'Installation/Configuration' started by anushanw, Feb 17, 2009.

  1. anushanw

    anushanw New Member

    I have followed all the steps given in the manual and so far it was going well till i started installing ISPConfig 3
    I started installing ISPConfig 3 with the SVN, selected the language and used the default (which are appropriate) values for the questions
    when it try to connect to MySQL server or the database it asked me the questions to enter hostnamme, username, password, database to crease, charset.

    Then it gave me an error saying:
    "Unable to connect to mysql server Can't connect to local MySQL server through socket 'var/run/mysqld/mysqld.sock' (2)

    Any idea what i should do?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that your mysql server is not correctly installed or running. Please redoo the mysql installation steps from the ispconfig 3 manual and make sure that you really started the mysql server.
  3. anushanw

    anushanw New Member

    i did install the mysql server and other things in step 1. howeever i re-did it right now and it gave me a sessage saying everything is uptodate.
    when i type the command "/etc/init.d/mysql restart" it displayed the following

    Stopping MySQL database server: mysqld.
    Starting MySQL database server: mysqld.
    Checking for corrupt, not cleanly closed and upgrade needing tables..

    and for "/etc/init.d/mysql status" it gives
    Server Version 5.0.51a-24
    Protocol version 10
    Connection Localhost via UNIX socket
    UNIX socket /var/run/mysqld/mysqld.sock
    uptime: 2 mins 2 sec

    Threads: 1 Questions: 78 slow queries: 0 Opens: 23 Flush Tables: 1 Open tables: 17 Queries per second avg: 0.639

    Any thing that you can think of???
  4. anushanw

    anushanw New Member

    Well it worked for one reason or the other when i asked for the status and re ran the installation process with the root password.

    Thank you for your help.
  5. RomaSvcs

    RomaSvcs New Member

    Can't connect to mySQL to /var/lib/mySQL/mySQL.sock

    I am using Centos 5.3 and I had the same problem, I solved this way...

    Removed ISPCONFIG3
    removed myDNS
    using phpmyadmin removed all ispconfig or mydns DBs and users


    reinstall myDNS
    reinstall ISPCONFIG3
    problem solved

    this steps should work on any linux distro.

    hope this help

    Carlos Barrera
  6. conductive

    conductive Member HowtoForge Supporter

    I get the
    Unable to connect to mysql server
    During a Wheezy ispconfig3 multiserver install.

    The Mysql server installation accepts special characters and passwords over 50 characters in length where ISSpconfig does not and may simply tuncate them.

    I have kept my passwords below 49 but I ended up with the same error when attempting to install the secondary DNS server.

    What are the ispconfig pw parameters?
    Is there a limit on the total number of characters in a multi server environment?
  7. conductive

    conductive Member HowtoForge Supporter

    The next server installed proverly so it appears that I improperly installed the DB credentials on one of the servers andd all is good if you keep passwords under 49

Share This Page