debian, lvm, raid, grub, custom kernel

Discussion in 'Installation/Configuration' started by koi, Jul 30, 2007.

  1. koi

    koi New Member

    Hi I have a problem.
    I have a debian etch stable.
    I made this setup:
    3 hd.
    3 x 1 gb for /boot raid 1 (out of lvm)
    3 x 15 gb for / raid 5 (lvm)
    3 x 20 gb for /home raid 5 (lvm)
    3 x 256 mb for swap raid 5 (lvm)

    I made all during the installation process. I have used lvm on raid 5 partitions.
    I have never used lvm before, "only" raid.

    The problem is that i have always recompiled kernel by vanilla sources, and i never used initrd cause the "important" things i am usual to put "built in " in the kernel configuration.

    This time, with lvm, it doesn't work:
    so: Do I have left something out of the kernel? (is dm-mod the part about lvm, right?) ?
    Do I need initrd the same?

    The error I get during boot is (after raid is corretly started):
    VFS: cannot open root device "mapper/name-of-the-volume" or unknown-block (0,0)
    Please append a correct "root=" boot option
    md0 (driver?)*
    kernel panic not syncing vfs: unable to mount root fs on unknown-block (0,0)

    * md0 is the raid 5 metadevice

    Thans in advance.
  2. falko

    falko Super Moderator ISPConfig Developer

    I'd create an initrd and try again to see if it works then.
  3. agrimstad

    agrimstad New Member

    Similar set up, similar problem

    Like the originator of this thread, I created logical volumes on top of software raid when I installed etch. Now I want to build my own kernel. I followed the steps in "How To Compile A Kernel - Debian Etch."

    The new kernel fails to boot because it can't find the root file system, which is a logical volume on top of a raid5 md. The first error diagnostic is "mdadm: no devices listed in conf file were found"

    Looing into the contents of the initrd, there's an mdadm.conf and an md.conf file. These are exactly the same as in the initrd of my working kernel. In fact, the whole md set up in the initrd looks to be exactly the same as that for the working kernel/initrd combination.

    Any ideas what's really wrong?
  4. agrimstad

    agrimstad New Member

    Further information

    In my initial attempt to build a custom kernel according to the howto recipe published here, I boldly attempted to go from to 2.6.22-10. Burned by that, I cautiously tried to go to, but using the vanilla source rather than source patched by debian and taking all the defaults when running make oldconfig (and in the initial stages of the build). Guess what? That worked following the recipe.

    So, I now have a custom kernel. Unfortunately, this doesn't deal with the problems that are driving me to my own kernel, namely limited support for the sensors on my motherboard and my WD hard drives, both of which are too new for

    I'm guessing something changed at some point along the road to kernel 2.6.22 which requires changes to one or more utilities such as those associated with mdadm or logical volumes. So my revised question is, how modern a kernel can I use without also building my own custom utilities programs? That is, staying the utilities in etch?
  5. agrimstad

    agrimstad New Member

    Never mind

    I spent the time working my way, one version at a time, from 2.6.18 through 19, 20, and finally to 2.22.10, using each time the .config from the previous build and make oldconfig. This got me to a working 2.22.10 kernel. So the problem I initially reported was just the result of some mistake I had made.

Share This Page