Directory Browsing 403

Discussion in 'Installation/Configuration' started by Sinisfun, Dec 31, 2005.

  1. Sinisfun

    Sinisfun New Member

    I cant seem to be able to enable directory browsing for certain files. What I would like to do is create a folder in my web dir named pics and then have images in there. However when I browse to www.xxxx.tld/pics I get a 403 error from ispconfig. I changed permissions of the folder to 755 775 777 and still none of them work. Am I missing something here?

    Thanks in advance for you help,

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look at your httpd.conf (can be also apache.conf or apache2.conf). At the end of the file you will find this:

    <Directory /home/www/*/web>
    Options +Includes +FollowSymlinks -Indexes
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all

    <Files ~ "^\.ht">
    Deny from all

    There you must change the line:

    Options +Includes +FollowSymlinks -Indexes


    Options +Includes +FollowSymlinks +Indexes

    to enable directory browsing. If you dont want to enable directory browsing for the whole server, you can put an .htaccess file in your pics directory with the line:

    Options +Indexes
  3. Sinisfun

    Sinisfun New Member

    When I do the .htaccess method in the pics folder, I now get a 500 internal server error. This is the method I would like to use as there are dirs that I would rather not have browsable. Any ideas as to what may cause this?
  4. Sinisfun

    Sinisfun New Member

    I was able to resolve this.... I was using coreftp and I was placing a .htaccess file in the folder I wanted to list files from, however there was an .htaccess file in the "Web" dir and I believe my pics was inheriting its permissions. I deleted that file and now it list the files.

    Thanks for pointing me in the right direction:)
  5. greenpete

    greenpete New Member

    I did this and it worked!:)
    But now (even though I have changed back) I can't access the ISPConfig admin panel.:(
    Any ideas?

    Running The Perfect Setup - Ubuntu 6.06 LTS Server (Dapper Drake) plus Webmin
  6. falko

    falko Super Moderator Howtoforge Staff

    What's the output of
    netstat -tap
    ? Any errors in the error log in /root/ispconfig/httpd/logs?
  7. greenpete

    greenpete New Member

    The netstat doesn't mean a lot to me and most of the log files seem to have no errors, but the 'error_log' says a lot!
    It's too big to post so you can download from here. (link now removed)
    It seems to me there are a lot of files disappeared and file permissions are wrong.
    Do you think I can repair this or should I use a backup image to reinstate things?
    The two domains I run are accessable on port 80 as usual, so I uess Apache is running ok there.


    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 3732/mysqld
    tcp 0 0 *:10000 *:* LISTEN 4336/perl
    tcp 0 0 *:ftp *:* LISTEN 3667/proftpd: (acce
    tcp 0 0 mail.swerfordhea:domain *:* LISTEN 4303/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 4303/named
    tcp 0 0 *:smtp *:* LISTEN 3779/master
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 4303/named
    tcp 0 0 *:49242 *:* LISTEN 13928/python
    tcp 0 0 *:49244 *:* LISTEN 2625/python
    tcp 0 12672 mail.swerfordheat:53546 bd641750.virtua.c:42651 ESTABLISHED2625/python
    tcp 0 8 mail.swerfordheath:smtp ESTABLISHED12646/smtpd
    tcp 0 1460 mail.swerfordheat:46556 S0106001839d525d7:30919 ESTABLISHED2625/python
    tcp 0 9856 mail.swerfordheat:56066 201-92-156-35.dsl:35066 ESTABLISHED2625/python
    tcp 0 0 mail.swerfordheat:50535 client-82-13-26-1:37842 ESTABLISHED2625/python
    tcp6 0 0 *:imaps *:* LISTEN 3606/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 3641/couriertcpd
    tcp6 0 0 *:pop3 *:* LISTEN 3621/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 3586/couriertcpd
    tcp6 0 0 *:www *:* LISTEN 31032/apache2
    tcp6 0 0 *:ssh *:* LISTEN 3905/sshd
    tcp6 0 0 *:smtp *:* LISTEN 3779/master
    tcp6 0 0 ip6-localhost:953 *:* LISTEN 4303/named
    tcp6 0 0 *:https *:* LISTEN 31032/apache2
    tcp6 0 144 mail.swerfordheath.:ssh 88-108-20-154.dyna:3774 ESTABLISHED12305/sshd: admin [
    Last edited: Apr 2, 2008
  8. falko

    falko Super Moderator Howtoforge Staff

    Did you play around with the SSL cert for ISPConfig?
    Do you get any errors when you start ISPConfig?
    /etc/init.d/ispconfig_server start
  9. greenpete

    greenpete New Member

    No I didn't mess with the certs, though I have been meaning to as they are deemed untrustworthy by some browsers!

    I don't get it, I ran the command above and it all works now, even when I re-boot!
    I would still like directory browsing to work though, but am unsure as to bother or not if it will kill my system?
    If someone could recommend how I could safely go about this I would be grateful.
  10. falko

    falko Super Moderator Howtoforge Staff

    Please try Till's solution again. It doesn't have any effect on ISPConfig as ISPConfig is running on its own Apache. Your ISPConfig problems must have been caused by something else.
  11. greenpete

    greenpete New Member

    I tried Tills soloution again and this time all is well.
    I have no idea what I did before that caused the trouble!
    Thank you again! :)
  12. greenpete

    greenpete New Member

    Oops, thought my post had failed so I posted again!
    Mods please remove this one, thanks.
  13. bhwong

    bhwong New Member

    I'm getting error 403 despite having .htaccess with "Options All +Indexes" inside the subfolder.

    I have also amend /etc/apache2/httpd.conf by changing "Options +Includes -Indexes" to "Options +Includes +Indexes" and executed
    /etc/init.d/apache2 restart

    What else did I missed? :(

Share This Page