Disable http2

Discussion in 'General' started by lnxgs, Nov 28, 2020.

  1. lnxgs

    lnxgs Member

    Hello,
    I've a old server with Debian Jessie (the old old stable) with Nginx. Such Nginx version does not support http2 but last version of ispconfig will enable it on configuration files. This leads to errors when Nginx is reconfigured. Where I can disable http2 support?

    Thank you
    L.
     
  2. ahrasis

    ahrasis Well-Known Member

    Preferably in ISPConfig CP but I always thought ISPConfig will detect that before showing the option to allow you to use http2.
     
  3. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Which version of nginx are you using? We might have to fix it in the template.
     
  4. lnxgs

    lnxgs Member

    We decided to migrate to a new operating system becuase Jessie is too old now.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Just for reference: You can do that by creating custom nginx templates for the website vhost, ispconfig vhost that don't use http2.
     
    Th0m likes this.
  6. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Alright. Jessie wasn't supported anymore by ISPConfig, that explains the crashes.
     
  7. ahrasis

    ahrasis Well-Known Member

    I think this previously was related to spdy settings which can be turned off, but since the user is upgrading, and hopefully installing nginx with http2, this shouldn't be a problem anymore.
     

Share This Page