disable SpamAssassin and ClamAV and amavis

Discussion in 'Tips/Tricks/Mods' started by darkhoros, Sep 25, 2009.

  1. darkhoros

    darkhoros New Member

    I have already read the other posts related to same issue and googled enough, but no clear and direct how to, and I just got my ispconfig 3 installed on a vps and I am so afraid to miss things up.

    So as title says how to disable all 3 services( SpamAssassin and ClamAV and amavis), as I only need the apache and mysql service on this vps for a high traffic web site, no email options is needed, and when ever things change i can re-enable what I need of them.

    Help is apriciated alot.

    Thank you all.
  2. damir

    damir New Member

    Disable the mail module in ispconfig3 under System/Edit Server and than shutdown the services on the server.
  3. darkhoros

    darkhoros New Member

    first of all thank you for your kind reply, but I only need to disable these 3 services, I need the mail module running, just in case, I only need to free up the ram that these 3 services consume as they run.

    Thank you.
  4. robertlouwen

    robertlouwen New Member

    Hello Darkhoros,

    I am a Linux noob but I think when you use :

    "chkconfig --levels 235 amavisd on"
    "chkconfig --levels 235 clamd.amavisd on"

    to start ClamAV and Amavis at bootup


    "/etc/init.d/amavisd start"
    "/etc/init.d/clamd.amavisd start"

    to start ClamAV and Amavis again when manualy stopped.

    You can use:

    "chkconfig --levels 235 amavisd off"
    "chkconfig --levels 235 clamd.amavisd off"

    to prevent ClamAV and Amavis starting at bootup.
  5. darkhoros

    darkhoros New Member

    Thank you for your reply, it gave me some light.

    ok I used this to stop current running services.

    server# /etc/init.d/amavis stop
    server# /etc/init.d/clamav-daemon stop
    server# /etc/init.d/spamassassin stop

    they stopped and free about 150 MB of ram, very nice, I then editied the apache2.conf file and raise its resources, things went much better from there.

    I think using your way to exclude them from start up on boot will work once I change the services name, but I will try this later once I make sure that every thing is stable with my setup.

    Again thank you for lighting the way for me.:D
  6. mdjhomes

    mdjhomes New Member

    Thanks for the info, I appreciate it.
  7. phor

    phor New Member

    Isn't there a way to deactivate these 3 services and leave mail function working? When I simply stop the services, mails are deferred or rather aren't delivered.

    I want to use Mail but have no need for spam and virus checking.
  8. bnight

    bnight New Member

    Hi phor,

    I have the same problem as you have and I make some tests about howto disable Amavis on ISPConfig 3.

    Here is what you have to do to achieve this:

    Edit: /etc/postfix/main.cf

    Coment this two lines:

    content_filter = amavis:[]:10024
    receive_override_options = no_address_mappings

    Looks like this:

    #content_filter = amavis:[]:10024
    #receive_override_options = no_address_mappings

    Edit: /etc/postfix/master.cf

    And comment all lines bellow:

    amavis unix - - - - 2 smtp

    Looks like this:

    #amavis unix - - - - 2 smtp
    # -o smtp_data_done_timeout=1200
    # -o smtp_send_xforward_command=yes

    # inet n - - - - smtpd
    # -o content_filter=
    # -o local_recipient_maps=
    # -o relay_recipient_maps=
    # -o smtpd_restriction_classes=
    # -o smtpd_client_restrictions=
    # -o smtpd_helo_restrictions=
    # -o smtpd_sender_restrictions=
    # -o smtpd_recipient_restrictions=permit_mynetworks,reject
    # -o mynetworks=
    # -o strict_rfc821_envelopes=yes
    # -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
    # -o smtpd_bind_address=

    Now stop amavis-new and clamd:

    /etc/init.d/amavis stop
    /etc/init.d/clamav-daemon stop
    /etc/init.d/clamav-freshclam stop

    Now disable amavis and clamd form starting on system boot:
    chkconfig --levels 235 amavis off
    chkconfig --levels 235 clamav-daemon off
    chkconfig --levels 235 clamav-freshclam off

    Now you can restart postfix:

    /etc/init.d/postfix restart

    And you have working postfix without Amavis and Clamd.

    Good Luck.

Share This Page