DKIM & DomainKeys with Sendmail/Postfix:

Discussion in 'Installation/Configuration' started by niradev, Aug 22, 2008.

  1. niradev

    niradev New Member

    I installed and configured DKIM and DomainKeys milters for Sendmail by following the instructions from the following pages:

    The good thing is that I got these milters to sign all outgoing emails. However, the problem is that the signatures fail consistently for emails with a message larger than a certain size. For example, gmail says: dkim=neutral (body hash did not verify)

    For emails with a couple of sentences, the signatures always work as expected. I suspect that Sendmail is modifying the message in some manner after the email's been signed.

    I have Sendmail version 8.13.8 running on CentOS 5. I even tried using Postfix but with the same results.

    I would really appreciate some help here. Please let me know if I need to provide further information about my setup.

    Thank you very much!
  2. jabailo

    jabailo New Member

    openSuse 11.0, dkim-milter rpm

    I installed the dkim-milter from the rpm that is offered by openSuse on my openSuse 11 system.

    However I could not locate any documentation/manuals so I don't know how far I'm supposed to take the installation to complete it.

    I have looked at this HowTo for CentOS on HowtoForge.

    Can someone tell me if these same steps also apply to openSuse 11 from the step after installing the rpm?
  3. falko

    falko Super Moderator ISPConfig Developer

    I think the procedure might be slightly different (although I haven't tried), but nevertheless the tutorial should give you the idea.
  4. jabailo

    jabailo New Member

  5. Daniel Lam

    Daniel Lam New Member

Share This Page