dkim location not updates

Discussion in 'Installation/Configuration' started by Steffan, Nov 15, 2016.

  1. Steffan

    Steffan Member

    Multiserver setup 3.1
    dkim location is set in database sys_ini: /var/lib/amavis/dkim
    if i change this to
    changed the dkim location in the admin to /etc/postfix/dkim in the panel
    the settings are saved but sys_ini is not updated
    It is changed in table: server

    Is this a bug? do i need to change sys_ini manualy?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Make a bugreport in the bugtracker so we can check that or ask @florian030 , he might be able to tell you if there is an issue or not.
  3. florian030

    florian030 Well-Known Member HowtoForge Supporter

    The settings for dkim in server-config are the same as for other settings. But if you change the path, this does not affect your existings dkim-keys. They are store in the old folder and amavis uses the old folder, too. You have to resync the dkim-keys.
    Please keep in mind, that amavis must have (read) access to /etc/postfix/dkim.
  4. Steffan

    Steffan Member

    yes but that is my problem
    i change the location in the controlpanel, then database sys_ini is not updated with the new settings
    the changes has no effect on new created dkims
    they still get placed in /var/lib/amavis/dkim
  5. florian030

    florian030 Well-Known Member HowtoForge Supporter

    There is no difference between the dkim-path and other settings on this page. Did you choose the right server and is server configured as a mail-server?
  6. Steffan

    Steffan Member

    i have checked multiple times.
    also changed the config for all servers just to be shure
    in the controlpanel it says : DKIM Path: /etc/postfix/dkim
    but again when creating a key the foloowing line is eddited
    dkim_key('', 'default', '/var/lib/amavis/dkim/');

    Still the db field sys_ini is:

    I manualy changed sys_ini
    now it works
    but looks like a bug to me
  7. Steffan

    Steffan Member

    after the 3.1.2 update this problem is back :-(

Share This Page