DKIM stopped working

Discussion in 'Installation/Configuration' started by Cecik, Jul 31, 2014.

  1. Cecik

    Cecik New Member


    we have a problem.
    Long time ago, we set up DKIM for 3 domains, everything was ok,
    gmail didnt recieve it into SPAM.

    But now its moving into SPAM.
    Where could be problem?

    We tried to update to the newest version (0.3.2),
    everything seems to be fine (we tested keys > pass).
    Ofcourse we tried to regenerate them a few times.

    But Gmail is receiving into SPAM.

    Thanks for read and reply.

    If it helps, below you can see dns records:

    A ftp 0 1800
    A mail 0 1800
    A 0 1800
    A ns 0 1800
    A ns1 0 1800
    A www 0 1800
    AAAA 2a02:2b88:2:1::228a 0 1800
    MX 0 1800
    NS 0 1800
    NS 0 1800
    PTR 0 1800
    PTR 0 1800
    TXT v=spf1 mx -all 0 60
    TXT v=spf1 ~all 0 60

    And testing keys:
    And log email:
  2. florian030

    florian030 Well-Known Member HowtoForge Supporter

    Your amavis didn´t sign the mail:
    Jul 31 21:03:37 vm8842 amavis[21847]: (21847-05) Passed CLEAN, <[email protected]> -> <[email protected]>, Message-ID: <[email protected]> , mail_id: MtxfVTTtX0xd, Hits: -0.001, size: 1264, queued_as: 5892E20736, 460 ms
    If the mail was signed by amavis, you should see something like
    queued_as: 5892E20736, dkim_new=XXX
    in the log.

    You should also run
    amavisd-new testkeys
    to check that everything is fine with your key-pairs. I don´t know why you regenerate the keys a few times, but did you also update the dns-record?
    Last edited: Aug 1, 2014

Share This Page