DNS entries are not showing up

Discussion in 'ISPConfig 3 Priority Support' started by Spaetzle, Jul 9, 2016.

  1. Spaetzle

    Spaetzle Member HowtoForge Supporter

    I have set up a muti server environment (Panel, Web, Mail, DB, NS) with ISPConfig 3.1 with Ubunutu 16.04.

    Now I see a problem when setting up NS entries. The first zone I added seemed to show up correctly.
    After that I added another one for which some entries are available (the ones addes after doing the wizard). For this Domain I added some two more nameservers which do not show up when trying to get the data with dig.
    For testing I tried to add a TXT entry wich did not show up either. A third domain added doe not show anything at all when asking the service with dig.
    Any hints?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Spaetzle

    Spaetzle Member HowtoForge Supporter

    OK. What I have done:
    1. On the ISPconfig panel I set at the page "System - Server configuration <Entry for NS>" the setting for Loglevel to "Debug"
    2. On the NS I commented the line "
      #* * * * * /usr/local/ispconfig/server/server.sh 2>&1 | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done"
    3. On the NS i started:
    Output is just:
    /etc/bind# /usr/local/ispconfig/server/server.sh
    The pri.* files in /etc/bind did not change.

    But what I have observered when looking into the files is, that all wanted entries could be found in the files.
    The pri.* filed looks well formed to me to, but if file pri.*.signed look a little bit wired to me.
    Here I could find a part looking like this:
                                            MpQxFex85R/tprHvrA== )
    domainname.tld.domainname.tld. 3600 IN NS ns3.ns-domain.tld.
                            3600    IN NS   ns3.ns-domain.tld.
    mail.domainname.tld. 3600 IN A <IP of Mailserver>
                            3600    RRSIG .....
    I anonyminized IPs and domain names
    Could it be that there is a line break missing at the seventh line between the two "domainname.tld"?
  4. Spaetzle

    Spaetzle Member HowtoForge Supporter

    Maybe I found out the problem.

    I set a hostname for the NS Entry 3 and 4. And here I forgot to set a dot at the end of the Domain name.
    After putting this in it looks better. I will wait no until the updates are done and check again. Maybe this was a false alarm. I will let you know.
  5. Spaetzle

    Spaetzle Member HowtoForge Supporter

    It was an false alarm ...
    it was my failure. and correcting the host solved the problem ... sometime it is very helpful to talk about something ;-)

    Thanks again for reading ...

Share This Page