DNS Problem name server not finding records

Discussion in 'General' started by Nap, Feb 17, 2015.

  1. Nap

    Nap Member

    I'm running my own DNS server (as configured through ISPConfig). I have a number of domain zones setup and they've been working fine for some time.
    Today I added a new domain name which, including the TLD part, is 37 characters long. For this domain, I've setup 3 A Records (domain.tld, mail, www), an MX record, 2 NS Records (ns1,ns2), PTR Record, and a TXT Record for SPF. I've set these up exactly as I've done for the other domains I have.

    After pointing the doman name to my name servers (at the Registrant's web site) and waiting a 3 hours now, I'm still getting errors in my browser "Server Not Found". I have all the TTL's set to 300.

    When I use DIG @ns1.mymasterdomain.tld newdomain.tld I don't get any information back about the domain. Yet when I use another domain with the same name server, it provides all its records. When I use DIG newdomain.tld (in my home country) it is still returning the Name Servers of the Regestrant.

    I set my hosts file to point to my IP directly for this domain, and the website is showing as expected.

    I have 4 questions:
    1) Why is this one domain not working? Could it be due to the number of characters in its name?
    2) Why is DIG (using my name server) not returning info from my DNS server? (I've entered the records.)
    3) Why is DIG (using the regestrant's name server) returning the original Name Servers at the registrant after I changed them? (I understand there can be a long delay, but would expect that after 3 hours, their records should reflect my changes.)
    4) If I use DIG (without specifying a name server) I get different results depending on where I run the command, from Australia where I'm located and USA where my server is. (Seems like the changes aren't propagating.)

  2. Nap

    Nap Member

    I just discovered that in the /etc/bind folder, I have a file pri.newdomain.tld.err
    What would be the cause of that?
    I deleted the DNS Zone in ISPConfig, then I deleted the /etc/bind/pri.newdomain.tld.err file.
    I re-entered the DNS Zone in ISPConfig, and now (2) is solved.
    Last edited: Feb 17, 2015
  3. Nap

    Nap Member

    It's finally propagated through, and all is well.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    A .err file is written when BIND did not accept the zone due to errors. in such a case, you can check the .err file with the named-checkzone command or take a look into the syslog file.
    Turbanator likes this.

Share This Page