DNS problems?

Discussion in 'Server Operation' started by Sobrevia.Net, Jul 16, 2007.

  1. Sobrevia.Net

    Sobrevia.Net New Member


    Some time ago I posted a question about DNS problems, but they got solved without editing nothing some hours later.

    But now the problems started again, and I don't know what to do with them. The server can't resolve external domain IPs; when I do dig or nslookup of www.google.com, for example, it says:

    ; <<>> DiG 9.2.5 <<>> google.com
    ;; global options:  printcmd
    ;; connection timed out; no servers could be reached
    This is my /etc/resolv.conf:
    nameserver 8X.XXX.148.4
    nameserver 8Y.YYY.149.4
    The iptables -L results are
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    And the housing's company told me that there are no active firewalls in the network blocking the 53 port and that the two nameservers used are OK (I "shadowed" the IPs a bit, hehe).

    If I add "nameserver" on the top of /etc/resolv.conf, it begins to resolve right the local domains, but it still fails with the external ones.

    I don't know where to look now, so I'll be glad to listen to your opinions in order to try to mend that problem. Is there anything more I could try to do?
  2. falko

    falko Super Moderator ISPConfig Developer

    Please try this in /etc/resolv.conf:
  3. Sobrevia.Net

    Sobrevia.Net New Member

    Problem misteriously solved again

    Hi again, Falko.

    The troubles got solved again without aparently doing nothing. Well, this time we've catched some interesting data:

    · When I tried that DNS (I saw them in another thread and I thought I could try that), it was still failing.

    · We got the "master" domain (the one that have the dns1 & dns2 IN A regs pointing to the servers IPs) in the server itself, and we moved that to another one that was working right. When the new nameservers of the domain were updated, it began to work with our old /etc/resolv.conf file (not the one with your suggestion, which I changed back again after seeing that it didn't work). Anyway, it seemed the solution, but could not be the cause of the other post problems (the one I sent some weeks ago), because the first time it happened, that "master" domain was DNS hosted in another server.

    I looked at the /var/log/messages file and I only saw a lot of "lame server" warnings of some domains that aren't on the server, but I googled the entire message and saw that it was just a log I could deactivate without any other problems, so it wasn't the cause for that.

    All that things let me think that maybe was (another) temporary problem with some firewall in the network blocking the 53th port traffic, but I have no idea of what really happened.

    Do you have some other suggestions (like other important files in this kind of issues) for the next time it could happen?

    Anyway, thank you for your attention, and for all the contents on that forums, that are really really useful.

    I'll ask again if it begins to happen another time [I think it will, but I'd like it won't!]

Share This Page