Dns question

Discussion in 'Installation/Configuration' started by Mahir, Nov 7, 2005.

  1. Mahir

    Mahir New Member

    Hello i have a problem with the DNS, i wanne use the dns on the server that comes with ispconfig, so i maked 2 websites www.ermedia.nl and www.ulyaoth.com and clicked that it should make records.

    now it says my master dns server = www.ermedia.nl
    and my slave is also www.ermedia.nl since i buy my domainnames somewhere else i did there change dns servers to www.ermedia.nl it said accepted but now after 24hours i still can't reach my websites is there something i am doing wrong here?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which result do you get when you execute the following commands on your server:

    dig @localhost www.ermedia.nl
    dig @localhost www.ulyaoth.com
  3. Mahir

    Mahir New Member

    Hello till when i do that it gives the following:

    [root@duduk ~]# dig @localhost www.ermedia.nl

    ; <<>> DiG 9.3.1 <<>> @localhost www.ermedia.nl
    ; (1 server found)
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached
    [root@duduk ~]# dig @localhost www.ulyaoth.com

    ; <<>> DiG 9.3.1 <<>> @localhost www.ulyaoth.com
    ; (1 server found)
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached
    [root@duduk ~]#
  4. falko

    falko Super Moderator Howtoforge Staff

    It seems as if Bind isn't running on your server. (I guess it's also shown as offline in ISPConfig.) Try to start it. Depending on your distribution it's either

    /etc/init.d/named restart
    /etc/init.d/bind9 restart
  5. Mahir

    Mahir New Member

    This is what i get when i wanne restart :S

    [root@duduk ~]# /etc/init.d/named restart
    Stopping named: [FAILED]
    Starting named:
    Error in named configuration:
    zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700
    dns_rdata_fromtext: pri.12.222.213.in-addr.arpa:21: near 'www..ulyaoth.nl.': emp ty label
    zone 12.222.213.in-addr.arpa/IN: loading master file pri.12.222.213.in-addr.arpa : empty label
    _default/12.222.213.in-addr.arpa/IN: empty label
    zone ermedia.nl/IN: loaded serial 2005110704
    zone ulyaoth.com/IN: loaded serial 2005110701
    zone ulyaoth.nl/IN: loading master file pri.ulyaoth.nl: file not found
    _default/ulyaoth.nl/IN: file not found
  6. Mahir

    Mahir New Member

    wel i reinstalled the bind service and teh control panel now it say's the following:

    [root@duduk ~]# dig @localhost www.ermedia.nl

    ; <<>> DiG 9.3.1 <<>> @localhost www.ermedia.nl
    ; (1 server found)
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16316
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

    ;www.ermedia.nl. IN A

    www.ermedia.nl. 86400 IN A

    ermedia.nl. 86400 IN NS www.ermedia.nl.

    ;; Query time: 0 msec
    ;; SERVER:
    ;; WHEN: Mon Nov 7 12:58:23 2005
    ;; MSG SIZE rcvd: 62

    [root@duduk ~]#

    But i still can't reach the website :(
  7. falko

    falko Super Moderator Howtoforge Staff

    This is what I get when I run dig www.ermedia.nl:

    This means that www.ermedia.nl doesn't exist in DNS. BTW, the same goes for ermedia.nl. The authoritative name server for the domain is ns1.dootall.com. So you should contact the one who's responsible for that server and ask him to create the DNS records.
  8. Mahir

    Mahir New Member

    Ok maybe a stupid question but i wanne make on my own server the dns like

    ns1.ermedia.nl =
    ns2.ermedia.nl =

    how must i do this ? and that it will also work with ispconfig ?
  9. falko

    falko Super Moderator Howtoforge Staff

    For every domain you register you have to set authoritative name servers. There you say that ns1.ermedia.nl and ns2.ermedia.nl should be the name servers for the domain. Before you do that you already create the necessary DNS records in ns1.ermedia.nl and ns2.ermedia.nl. That's it.
  10. Mahir

    Mahir New Member

    Falko :) i don't really understand it (i am a tottaly newby to dns) do i have to change a configuration file of bind that it maked ns1.ermedia.nl and ns2.ermedia.nl as dns servers? or i just fill in in ispconfig ns1 and ns2 as dns servers?
  11. falko

    falko Super Moderator Howtoforge Staff

    No, at your registrar where you register your domains you can specify for each domain which name servers are responsible for that domain. So if you have a domain example.com and want to use ns1.ermedia.nl and ns2.ermedia.nl as name servers, then you have to tell you registrar that you want to use these name servers for example.com (most registrars have a web interface for their customers where customers can make these changes themselves).
  12. Mahir

    Mahir New Member

    yeah ok i understand that but don't i have to tell the world that my server is the dns server ns1.ermedia.nl ? because when i go to webinterface of my domain name and i say change dns servers and i do ns1.ermedia.nl and ns2.ermedia.nl it say's they don't exist thats what i mean i have to do something on my server i gues
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Before you can use the Domains ns1.ermedia.nl and ns2.ermedia.nl you will have to make two A or CName records on the DNS Server that currently handles the domain ermedia.nl (not on your ISPConfig Server!).
  14. Mahir

    Mahir New Member

    OK thank u very much :) hehe i am understanding it all now :)
  15. CJMostert

    CJMostert New Member

  16. stamy

    stamy New Member

    Step by step procedure to configue a DNS server

    For Mahir: some explanations about DNS system

    First you need to tell your registrar (the location you buy your domain) that you would like to use your ispconfig server for the primary domain name server for your domain.

    For me (broutille.com), i give gandi.net (my registrar) this information:

    As you can see, the first line is the primary DNS server and the second line is the secondary DNS server. The secondary DNS server is provided gracefully by my registrar (most registrar do that).

    The most important information on those lines is that when a DNS server is not known by the REGISTRY (dont confuse with the registrar) you must provide two informations, the name of the DNS server (ns1.broutille.com) AND the IP ADDRESS ( so the registry (Verisign for .com or .net, i dont known who is the registry for .nl) can register your DNS server in the internet registry, this is very very important, if not it will not work.

    Lets go further.

    After you do that you need to wait almost 24 hours for a .com domain, less for another tld like .net or .nl it depends on the registry ...
    In the mean time you can configure your ispconfig server.

    For the moment go under "DNS Manager" section (ispconfig server) and check the primary DNS server for your domain, it must be ns1.broutille.com (for me, for you you need to replace it with ns1.ermedia.nl) and as second DNS server you must put ns6.gandi.net for me and for you the secondary DNS server provided by dootall.com (i guess it is your registrar). This is the section DNS, tab "Options" (the second tab) => Names server1 and Name server2 ...

    You need to check if you have a "A" entry for ns1.ermedia.nl with the correct IP@

    Now you need to wait until the registry is updated with you ns1.ermedia.nl IP@ ... it can take 24 hours.

    But you can check with dig @ ermedia.nl to see if your DNS server is working or not, when the registry is updated you can check with dig @ns1.ermedia.nl ermedia.nl ....

    But if you want to manage the two DNS servers (primary and secondary) keep in mind that it must be two IP@ and if possible two differents servers (not on the same computer in case of a failure) because the secondary DNS server receive half of the DNS requests for your domain, it is not here only when the primary DNS server is offline ...

    In that case you need a second ispconfig server and to configure a slave dns server on it (and dont forget to give this IP@ of the secondary DNS server to the primary DNS server) ...

    I hope it was clear enough, at least it is working fine for me.
  17. CJMostert

    CJMostert New Member

    Server do not start!


    This morning my server does not even wana start...:mad:
    the details are as follows:
    Bringing up Loopback interface:       OK
    Bringing up interface eth0:             OK
    Starting system logger:                 OK
    Starting Kernal logger:                   OK
    Starting irqbalance:                      OK
    Starting named:
  18. falko

    falko Super Moderator Howtoforge Staff

    You might have to wait a few minutes and then check your logs for errors. Maybe there are errors in named.conf.
  19. CJMostert

    CJMostert New Member

    Not starting...

    Hallo... as i said previously my server does not even start now. It gets to the Fedora loading screen where you can click on the "link" to see more detail on HOW the Fedora system loads and at that stage it just hangs on the loading of the named service, I could try and leave it for the night and see if it does go further BUT i did previously let it run for some time but it did not progress further than this stage.
    :( :confused: I am so sad as everything went so well but now it seems all just goes noware AND i realy do not want to rebuild the server as this will be the 3rd time then I do the installation.
    :eek: PLEASE HELP :eek: me get my server up and running again!!!

    I entered the system with the install DVD and went into Resque mode but when i did "tail" it seemed to show me the last few lined of the just started system so I do not know how to see the FAILED log lines. I also am not sure where the named.config file is and if I find it can i just delete it or how will i know what is wrong in it to fix it... I much rather prefer to fix it and not delete the file and start from scratch.

    Thanx again

    Good news... Ok almost good news...
    BOOT 1. I went into Interactive mode for the start and found out if i do NOT start the "named" service the system can go on BUT if i then start the "FirstBoot" the system just gives me a blue screen...

    BOOT 2. I then tried a second time... No start on "named" AND No start on "FirstBoot" but when i started the ISPConfig service it does:
    /root/ispconfig/httpd/bin/apachectl startssc: httpd started
    And then it hands...

    BOOT 3. I then tried a third time... No start on "named", No start on "FirstBoot" AND No start on "ISPConfig" and YEA!!!! i can log on now.

    So what do I do now??? AGAIN I would prefer not to start over so if I can just fix it I would prefer that.

    Last edited: Aug 17, 2006
  20. falko

    falko Super Moderator Howtoforge Staff

    It's /etc/named.conf.
    Also check /var/log/messages and /var/log/syslog for errors.

Share This Page