DNS Recyle bin not emptying, DNS named.conf not being updated

Discussion in 'General' started by mcinallym, Apr 16, 2008.

  1. mcinallym

    mcinallym New Member

    I am extremely concerned.

    We have several hundred websites running on ISPConfig, with several resellers.

    The problem is, DNS entries in the DNS manager are not removed when clearning the recycling bin.

    Also, named.conf is not being updated AT ALL.

    So, new DNS entries are not going into named.conf.

    I just upgraded to the newest stable version: ISPConfig 2.2.22, and tried again, still no luck.

    There are no errors in ispconfig.log.

    Someone please help!

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    It might be that the permissions of the BIND directory are not correct. Please compare the permissions of the BIND config directories with the perfect setup guide for your linux distribution.

    Also have a look in ISPConfig at Management > server Settings on the dns tab if the bind config directory is set there correctly.
  3. mcinallym

    mcinallym New Member

    The permissions are correct for Cent OS 4.4

    It may also be worth noting that I have several *rogue* DNS entries that will not delete. I have renamed them to names like test12345.com so they are not used.

    Any other ideas?

  4. falko

    falko Super Moderator ISPConfig Developer

    Are the settings under Management > Server > Settings > DNS correct?
    What's the output of
    ls -la /root/ispconfig
  5. mcinallym

    mcinallym New Member

    Actually, I found it myself a couple of hours ago

    Zonefiles Dir

    magically changed to /etc/bind/

    I have no idea why it would do this.

    I am the only person with the access levels on the server to do it.

    Now, this is the 3rd time this has happened.

    Why is it happening?

  6. falko

    falko Super Moderator ISPConfig Developer

    Because the permissions of /var/named/ and its subdirectories are not correct. Please run
    chmod 755 /var/named/
    chmod 775 /var/named/chroot/
    chmod 775 /var/named/chroot/var/
    chmod 775 /var/named/chroot/var/named/
    chmod 775 /var/named/chroot/var/run/
    chmod 777 /var/named/chroot/var/run/named/
    cd /var/named/chroot/var/named/
    ln -s ../../ chroot
  7. mcinallym

    mcinallym New Member


    Nobody but myself has permission to change those folders.

    And I hadn't.

    I updated the permission changes as per perfect config CentOS 4.4.

    Is there a bug in ISPConfig that would cause the permissions to be changed?

  8. till

    till Super Moderator Staff Member ISPConfig Developer

    No. ISPConfig is naot able to change the permissions itself.

    I guess that you installed a bind update which might have reset the permissions.
  9. mcinallym

    mcinallym New Member

    OK, that is a possible explanation.

    I'm not sure why a bind update would alter file / folder permissions, but I will have to make sure things are OK then next time a server update is done.

    Thank you for you help!


Share This Page