DNS service and files

Discussion in 'Installation/Configuration' started by jeanjacquesjeanjacques, Nov 23, 2005.

  1. Hello,

    I'm sorry to bother you with this again but i really don't find any answers.

    I've made an /init.d/bind stop and when i go to see inside ISPconfig services panel the bind server stills online, i really don't get it.
    What can i do to stop the bind service associated with ISPconfig ?

    I would like to know if i create a domain using ISP config where will it put the files related to that domain ?

    Thank you for your help,

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    In ISPConfig go to Management > Server > Services. Set the status for DNS to Off and hit safe.

    /home/www/www.yourdomain.com/web/ or /var/www/www.yourdomain.com/web/ or in another webroot if you chose an other path as you installed ISPConfig.
  3. DNS files et default config

    Ok thank you for this, it's working perfectly.

    I have followed the default installation but all my files are located inside /home/www/my.wesite.net

    I'm still very confused because i thought that my DNS zone file related to my website would be also be in this folder but it's not, i'm not sure but after spending some time to look for it i believe that the file is located inside the /etc/bind folder.

    I have also tried to see if the zone file generated by ISPconfig was correct but apprently not, http://dnsreport.com/tools/dnsreport.ch?domain=eatn.net
    What am i doing wrong ?

    Best regards,

  4. falko

    falko Super Moderator Howtoforge Staff

    Yes, and your html files, php, etc, goes into /home/www/my.wesite.net/web.

    It depends on your distribution where the DNS files are. For Debian and Ubuntu it's /etc/bind, for others it might be /var/named, /var/lib/named, ...
    Is your nameserver authoritative for your domain? Do you use one or more nameservers for your domain? Do they have static public IP addresses, or are they in a local network?
  5. dns with isp config

    Thank you Falko for your precious help, it's very nice. :)

    I have one server which is doing dns, http(s), php and mail under debian stable.
    So yes i have only one nameserver for my domains.
    I have one static public adress for 3 different domains.
    My server is connected to the internet thru a router (i have configured a NAT table on this router to forward to my server port 80, 81,53,110 etc..).

    Before using ISPconfig everything was working properly, so i presume i have to learn how to user ISPconfig properly because it's such a fantastic and powerfull tool !

    But i've readen the admin's doc one more time but i don't really find complementary informations about how to set up my dns correctly.

    Do you know what's wrong ?

    This is my pri.eatn.net file:
    $TTL        86400
    @       IN      SOA     ns1.eatn.net. admin.eatn.net. (
                            2005112406       ; serial, todays date + todays serial #
                            28800              ; refresh, seconds
                            7200              ; retry, seconds
                            604800              ; expire, seconds
                            86400 )            ; minimum, seconds
                    NS      ns1.eatn.net.              ; Inet Address of name server 1
                    NS      ns2.eatn.net.              ; Inet Address of name server 2
    www  MX      10 strategic-monitoring.com.
    eatn.net.      A
    ns2.eatn.net       A
    ns1.eatn.net       A
    eatn.net       A
    www.eatn.net       CNAME  eatn.net.
    Last edited: Nov 24, 2005
  6. falko

    falko Super Moderator Howtoforge Staff

    Did you forward port 53 TCP and UDP from your router to your server?

    I doubt that you want this:
    I guess you want

    because you want to send emails to <user>@eatn.net and not <user>@www.eatn.net, right?

    O, I tried a dig eatn.net and got no answer section which means there's something wrong. I guess the problem is that ns1.eatn.net is the authoritative name server for eatn.net. It's the hen <-> egg problem. Try to use another domain for the name server.
  7. rosa hsiao

    rosa hsiao New Member

    I have the same problem. Do you mean that ns1.eatn.net should use other Managed DNS server first and then ns1.eatn.net can become authoritavie name server for eatn.net or other virturn domains?
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    ns1.eatn.net can only become autoritive nameserver for other domains, but never for itself (eatn.net).
  9. rosa hsiao

    rosa hsiao New Member

    If I registered test1.com.tw at ISP "octor.com" and want to use dns.test1.com.tw as my nameserver for test1.com.tw. I have to use ISP's Managed DNS server at rsdn1.octor.com to resolve dns.test1.com.tw to my external IP address first. Then I can use dns.test1.com.tw to act as a nameserver for test1.com.tw and test2.com.tw or other domains. Am I right or still misunderstaning something?
  10. falko

    falko Super Moderator Howtoforge Staff

    You're still misunderstanding something. You can't use dns.test1.com.tw as name server for test1.com.tw, as Till mentioned above:

  11. Smitty

    Smitty New Member

    ... let me understand this correctly...

    If I register my new domain (i.e smittydomain.com), and I wish to operate my own authoritative nameserver for that same domain (i.e ns1.smittydomain.com), you're saying I can't do that (without dependence upon an already registered nameserver elsewhere)? My domain registrar has told me they can register my nameserver at the same time that I register my new domain as part of the single registration process for my new domain.

    Do all registrar's not have the capability to register the nameservers for that same domain, if called upon to do so?

    .. not wishing to get caught in the stumblings of which came first - the chicken or the egg.

    .. in advance, thanks.

  12. falko

    falko Super Moderator Howtoforge Staff

    I recommend that you register a "technical" domain (a domain you use for technical purposes only), then create ns1.<technicaldomain> and ns2.<technicaldomain> as A records, and then use these name servers when you register other domains.
  13. wkdboi

    wkdboi New Member

    need help with isp config and bind dns

    Hi All,

    I have installed Cent OS 5 and ISP Config.

    I log into ISP config it tells me bind dns = offline

    I don't know what is wrong.

    Domain is www.mad2.co.uk and have set up bind to use ns1.dnsmaster.net for www.mad2.co.uk IP for Nameserver is

    And I am using my Static IP for all other domains so in effect a loopback on itself. I have opened tcp/udp port 53 to the server but can't get any local domain like 1.mad2.co.uk to work.

    If anyone can help would be much appreciated

    Many Thanks

    Linux Webserver Newbie
    Last edited: Jun 26, 2007
  14. falko

    falko Super Moderator Howtoforge Staff

    What's the output of
    netstat -tap
    ? Any BIND errors in your log files?
    Did you disable SELinux? Did you use the "Perfect Setup" for CentOS 5.0 to set up your server?
    Which DNS server is the primary nameserver for your domain?
  15. wkdboi

    wkdboi New Member

    Primary name server is ns1.dnsmaster.net My domain register is Skymarket so it's their dns server
  16. falko

    falko Super Moderator Howtoforge Staff

    BIND is running, I can see it in the output ot netstat -tap.

    So did you create slave zones then for mad2.co.uk on your ISPConfig server?

    Can you run
    dig @localhost mad2.co.uk
    on your ISPConfig server? What's the output?
  17. wkdboi

    wkdboi New Member

    [root@server1 ~]# dig @localhost mad2.co.uk

    ; <<>> DiG 9.3.3rc2 <<>> @localhost mad2.co.uk
    ; (1 server found)
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 8971
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

    ;mad2.co.uk. IN A

    mad2.co.uk. 86400 IN A

    mad2.co.uk. 86400 IN NS ns1.dnsmaster.net.
    mad2.co.uk. 86400 IN NS ns2.dnsmaster.net.

    ns2.dnsmaster.net. 172680 IN A

    ;; Query time: 3 msec
    ;; SERVER:
    ;; WHEN: Thu Jun 28 22:18:36 2007
    ;; MSG SIZE rcvd: 109
  18. falko

    falko Super Moderator Howtoforge Staff

    It's responding at least.

    Two problems:
    Why do you use a local IP address? Nobody is then able to access your site from the outside...

    2) I get this:
    mad2.co.uk.             43200   IN      A
    which means that the primary DNS has stored another IP address for the domain than your own DNS server. This leads me to the assumption that you set up the mad2.co.uk zone as a master zone instead of a slave zone on your own nameserver...
  19. wkdboi

    wkdboi New Member

    Hmmm this could very well be true I set everything up using ISP config so how do I go about checking and changing to slave dns

    Copy of named.conf

    [root@server1 etc]# nano named.conf

    GNU nano 1.3.12 File: named.conf

    zone "1.mad2.co.uk" {
    type master;
    file "pri.1.mad2.co.uk";
    zone "mad2.co.uk" {
    type master;
    file "pri.mad2.co.uk";

    zone "ns1.mad2.co.uk" {
    type slave;
    file "sec.ns1.mad2.co.uk";
    masters {; };

    Last edited: Jun 29, 2007
  20. falko

    falko Super Moderator Howtoforge Staff

Share This Page