DNS Zones not activated any more

Discussion in 'General' started by 2Björn, Jun 20, 2023.

  1. 2Björn

    2Björn New Member

    we are using an ISPconfig3.2.7p1/Ubuntu20.04 server to host some DNS zones. Currently, there are 14 working zones, but the last two I added were not activated in named.conf.local the zone files are available and do not have an err-suffix.
    • Doing a diff with an activated zone file only shows domain differences, different timestamps and DMARC key.
    • named-checkzone returns OK
    • adding the zone manually to named.conf.local activates the zone (it will be removed by further edits within ISPconfig again)
    • There are no bind/named error messages in syslog
    • there are no messages in ispconfig logs
    As a temporary workaround, I'll include an additional named.conf.local2 with the zone definition, but I'd like to find the real reason, why ispconfig does not activate the zone. What problems could I look for? Any additional ideas?

  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    This has instructions for troubleshooting when ISPConfig fails to write changes to disk:
    My guess is the zone you added has something ISPConfig considers erroneus, and fails to write to the zone file.
    Using named-checkzone does not help in this situation, it needs as parameter the zone file that has errors.
  3. 2Björn

    2Björn New Member

    Hi Taleman, thanks for the reply
    The zone-file is there, I tried to expain this in my initial post.
    • it looks correct
    • if I compare it to another zone file, one that is working, there are no differences that should not be there
    • I ran named-checkzone with "named-checkzone info.mydomain.com /etc/bind/pri.info.mydomain.com", result is "OK"
    • if I manually add the zone-loading-block to named.conf.local and reload named, the zone is active and responds to requests like it should
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please see the link that @Taleman posted, it contains instructions on how to debug your issue in ISPConfig using debug mode.
  5. 2Björn

    2Björn New Member

    Hi Till,
    thanks for this additional info - debug mode was the thing I was looking for. The master server had a column rendered_zone in dns_soa that was not available on the DNS server. Without changing to debug mode, this error was not shown and even then, it only showed up in the logfile and not within the ispc web-interface. Within the web interface, there were only messages telling me that named.conf.local was written successfully.
    Adding the column rendered_zone solved the problem.
    Th0m likes this.

Share This Page