domain points to wrong directory

Discussion in 'General' started by PermaNoob, Nov 8, 2010.

  1. PermaNoob

    PermaNoob Member

    I've got one domain in my ISPConfig3 server that is pointing to the wrong directory.

    I've looked at the vhost file in sites-enabled and sites-available and they both look correct with the correct directory.

    Any ideas?

    Nvm--I forgot to select the ip address in the Web Domain setup in the controlpanel.
    Last edited: Nov 8, 2010
  2. paloke

    paloke New Member

    I have the same problem.

    After upgrade from a previous version, every time that i tried to load a domain with the same IP appear every time the same domain, first of the list.

    For example, when i try access to or the reached domain is

    All the IP-Address options are ok. The Auto-Subdomain are * (I tried www and none with the same results)

    In the DNS options all the domains settings are properly configured.

    The vhost seems to be ok.

    Do you have any idea?
  3. falko

    falko Super Moderator ISPConfig Developer

    Did you select the correct IP address for your web sites in ISPConfig?
  4. paloke

    paloke New Member


    Yes, I checked again all the IPs in the DNS config and in the website configuration. All the IPs are correct.
  5. paloke

    paloke New Member


    After read the message from jtheed:

    I solved (my) problem.

  6. EdjeB

    EdjeB New Member

    Re: Solved --> solved for me too

    This suggestion solved my issue as well. It was exactly the same. ?????
    This is apparently a bug? It is at least not something you'd like to encounter in a heavily used production environment.
    Will this be resolved in the next version?

    Kind regards,
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    This happens when someone or something (e.g. a Linux update) overwrites the ispconfig configuration file which contains the namvirtualhost lines. The procedure forces the rewrite of that file.

    As the procedure forces ispconfig to rewrite the config file and it gets written correctly, you see that its not a ispconfig bug.
  8. EdjeB

    EdjeB New Member


    Thanks for the info. I appreciate it.


Share This Page