DRBD/HA/OpenFiler issue with 'service openfiler start'

Discussion in 'HOWTO-Related Questions' started by CodeChris, Dec 17, 2009.

  1. CodeChris

    CodeChris New Member

    I'm having an awful problem with what seams to be a very good guide


    I have run through it, but I am stuck and trying to start the service openfiler, I have run through the guide, though I left out the configuration bit of NFS, iSCSI etc to keep it simple to start with but when I try to start openfiler I get an error. I can start drbd and heartbeat fine...

    [[email protected] ~]# service openfiler start
    Starting openfiler: grep: /opt/openfiler/etc/httpd/conf/httpd.conf: No such file or directory
    /bin/bash: /opt/openfiler/sbin/openfiler: No such file or directory [FAILED]

    [[email protected] ~]# service drbd status
    drbd driver loaded OK; device status:
    version: 8.2.7 (api:88/proto:86-88)
    GIT-hash: 61b7f4c2fc34fe3d2acf7be6bcc1fc2684708a7d build by [email protected], 2008-11-12 16:47:11
    m:res cs st ds p mounted fstype
    0:cluster_metadata Connected Primary/Secondary UpToDate/UpToDate C
    1:vg0drbd Connected Primary/Secondary UpToDate/UpToDate C

    [[email protected] ~]# service heartbeat status
    heartbeat OK [pid 6764 et al] is running on offsan1.domain.com [offsan1.domain.com]...

    This error appears the same on both nodes, so the GUI is down... Anyone had this before and know what might be wrong?

    Many Thanks
  2. padonker

    padonker New Member

    This howto doesnt work correctly with OF 2.3 and nobody responds to questions :mad:
  3. spinracing

    spinracing New Member

    Working with the exact same issue myself.

    I had run through the howto previously, in its entirety, but the boxes I built do not have SCSI drives, they are SATA. I also had to copy the instructions and change out the sections for my own drives, as they didnt jive with the instructions. After going through the Samba, SCSI and FTP portions I realised I really didnt need them. Everything worrked properly until I made the last couple pages of changes. Then the whole thing wouldnt boot on either box.

    After re-installing the works, and getting things up and running (Add 1 week of work.. Zeroing new drives bites.) Things were all perfectly fine until the last batch of configuration changes.

    I skipped the SAMBA/NFS section, iSCSI, and FTP.

    From there things got a little ugly.

    The first issue I ran into was the /meta partition got renamed. And the system wouldnt boot. So I had to re-boot with a Unbuntu 9, external CD-Rom setup.. so I could go in and change the partition back to /meta.
    After that on both boxes things were better, although I had to re-associate some of the "ln"s that were preventing things from working properly.

    After a day of tweaking things to make sure all the files are in the directories they are supposed to be in, and re-creating links.. my primary box is up and running fine. I can connect to its web interface with no issues.

    The second box however has the issue listed above. Openfiler service will not start.

    Also I have not started searching out the answers yet but the re-mapped GUI interface for both boxes is not available yet. SO thats the next issue.

    One of the things I found.. a lot of the links between files re-mapping them didnt take for some reason, or needed to be re-done. That has fixed some of the issues.

    Also the primary box's drives keep losing primary status, as well as the secondary box keeps staying as secondary/secondary.

    LOT of troubleshooting sofar. And not a plug and play install by any means.

  4. howtoforgeisz

    howtoforgeisz New Member


    I saw the problem you are having with the inability to start the openfiler service. I just recently installed OpenFiler following the same tutorial on this site and encountered the same error; however, I don't think it's really a problem, and perhaps maybe by design.

    Is [email protected] your secondary node? If so, you won't be able to start the OpenFiler service. This is automatically started by Heartbeat after a failover has occurred.

    For example, I am running both nodes in virtual machines, and after pausing my primary, the failover is initiated. On the secondary node, a message should be presented after the failover completes telling you "You have new mail in /var/spool/mail/root".

    On the secondary node, drbd will look like this:
    m:res               cs            ro               ds                 p  mounted            fstype
    0:cluster_metadata  WFConnection  Primary/Unknown  UpToDate/DUnknown  C  /cluster_metadata  ext3
    1:vg0drbd           WFConnection  Primary/Unknown  UpToDate/DUnknown  C
    The httpd service does not apply, because I believe the OpenFiler service is acting as a web service. At this point running service openfiler status should return that the service is running, and you can access the node via the virtual IP you defined in the setup instructions. When you look at the Status page in the web UI, it should indicate that it is looking at your secondary node.

    Finally, you can look at /opt/openfiler/etc/httpd/conf/httpd.conf, since now the file will exist.

    I am a novice as well, but I hope this helps and represents accurate information.

    Good luck!
    Last edited: May 31, 2010

Share This Page