Dynamic DNS & DNS

Discussion in 'General' started by Plascual, Feb 21, 2006.

  1. Plascual

    Plascual New Member


    I registered a domain name with EasyDNS with DNS-Plus service (I'm on cable, behind a router with forwarding) and would like to setup a development web-server.

    I installed a "Debian perfect setup" + ISPConfig successfully with external IP and domain name.

    I'm a little bit confused about DNS and Bind9 and ISPConfig, because EasyDNS provide control panel to manage A records, and I configured nameservers to those of EasyDNS.

    - Should I turn off Bind9 and how?
    - Should I point to their nameservers?

    There is no problem seeing the ISPConfig server from outside, but I have difficulties to set subdomains as "user1.example.com" and "user2.example.com" so that they point to different web pages.

    Should I add IPs to /etc/hosts for each subdomains?

    Does anybody know examples on how to setup ISPConfig with dynamic DNS with nameserver of i.e. EasyDNS?
  2. falko

    falko Super Moderator Howtoforge Staff

    If you use EasyDNS to manage all your DNS records, then yes. You can use the ISPConfig interface to turn off Bind: Management -> Server -> Services.

    No, that's not necessary.

    Just create the appropriate DNS records for user1.example.com and user2.example.com with EasyDNS, and then create two new web sites in ISPConfig, one for user1.example.com, the other one for user2.example.com.
  3. Plascual

    Plascual New Member

    Thanks falko!

    In Management > Server > Settings > DNS > Default Ns1 : Ip adresses or ns1.easydns.com or my ISP nameserver or any of theses? :)

    Something strange, in Services, the Web-Server is Offline...

    If I "netstat -tap" some entries end with "TIME_WAIT"...

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If you use easydns to manage your dns records, you can leave these fields empty. They are just the defaults that are inserted when you use the DNS-Manager in ISPConfig.

    Can you please post the output of "netstat -tap". I guess your apache webserver is not listening on localhost.
  5. Plascual

    Plascual New Member

    Thanks you!

    You were right Till, I changed listening port to 8080. I put it back to 80, with my router forwarding external port 8080 to internal 80 of my server IP.

    So, being with EasyDNS, I switched off DNS-Server. With EasyDNS panel, I created A record "server1.example.com" that has an URL to "https://IP-adress:81/" and A records "user1.example.com" and "user2.example.com" with IP.

    The ISPConfig on "https://server1.example.com:81/" respond from the outside without any problem.

    I created the two clients and their respective websites.

    When I type address "http://user1.example.com:8080" or "http://user2.example.com:8080", I'm redirected to "http://user#.example.com:8080/apache2-default/" ...

    Is it a DNS problem?

    I expected to see the user1.example.com page with the blue stripe. :confused:
  6. falko

    falko Super Moderator Howtoforge Staff

    Did you create a web site for user1.example.com in ISPConfig (or added user1.example.com to another web site as Co-Domain)?

Share This Page