ERROR 403 permission and access problem

Discussion in 'General' started by isopure, Oct 8, 2005.

  1. isopure

    isopure New Member


    I have installed ispconfig 2.0.9 on Debian Sarge as per the great instructions provided.
    When it comes to sites, I am able to create directories under the web directory, but I am unable to access these directories. i.e. or anything under these directories. I get a 403 error which states to following

    The following error occurred:
    You are not permitted to access the requested URL
    Please contact the Webmaster with any queries.

    I verified ownership of directory and access permission and all seems well but I keep getting the 403 error.
    Any help will greatly be welcomed.

    Thx in advance.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You are shure that the DNS A-Record for the Domain points already to your server. This may take up to 2-3 days.
  3. isopure

    isopure New Member

    The DNS A-record has resolved itself about 4 days ago. I am able to access the site i.e. and any file that is in the web root, but again when it comes to any directories made in the web root and access file from it... I get the error. do i have to create .htaccess for each site and set-up permissions there... under which directory

    This is what my apache2.conf looks like:

    <Directory /var/www/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all

    Thx again
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    There are no additional htaccess files nescessary.

    Can you please post the output from the comand "ls -la" for the directory image and the file somepic.jpg
  5. isopure

    isopure New Member

    the output is as follows from "ls -la"

    drwxrw-r-- 2 web3_obed web1 4096 Oct 7 17:21 images
    -rw-r--r-- 1 web3_obed web1 139015 Oct 9 11:12 somepic.jpg

    but the user that should own the dirctory is web1_admin... would it make a diff if I chown -R the file and directory to web1_admin:web1 when it comes to ispconfig.

    again thx for the quick reply
  6. falko

    falko Super Moderator Howtoforge Staff

    Directories must have execute permissions for each user/group. But the images directory only has execute permissions for the owner.
    If you run
    chmod 775 images
    chmod 755 images
    then it will work.
  7. isopure

    isopure New Member

    thx guys for your help...
    problem was has been solved; and it was partly due to permission and ownership.

    great app; and great community support.
  8. smuir111

    smuir111 New Member

    I did the CHMOD and it still doesn't work.

    any ideas?
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Are the images in the correct directory? Make shure that you are not accessing for example the sharedip directory accidently.

    By the way, please make a new thread for your problem.

Share This Page