Error 404 - stats

Discussion in 'Installation/Configuration' started by migratoria, Apr 8, 2022.

  1. migratoria

    migratoria New Member

    Hi friends
    I have installed ispconfig in my new server.
    When I created the domain, the "/stats" folder was also created automatically.
    Then I deleted the /stats folder to paste the old /stats folder present on the my old server. When I access I get the 404 page not found error but the folder exists and contains all the files. I also tried to delete and recreate it from the ispconfig panel. The folder is created but then does not login, generating 404 page not found error.

    If I delete the .htaccess and .htpasswd stats files then I can see the contents and statistics correctly

    Can someone help me figure out where is the problem?
  2. migratoria

    migratoria New Member

    I also tried to assign client/web permissions to the stats folder instead of root/root but the result doesn't change.
    In other 2 of my domains on the same server, the original /stats folder created by ispconfig during installation works correctly
  3. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

  4. migratoria

    migratoria New Member

    yes, once the /stats folder is deleted, even if I recreate it from the statistics panel or via ftp, the access via authentication does not work and reports the error "Page not found".

    But the folder was created successfully and the statistics work if for example I delete .htaccess and .htpasswd_stats.

    I also tried to recreate a new password using the "Protected folders" option from the ispconfig panel. The files are created but the result does not change.

    While 2 other domains always present on ispconfig that use the /stats folder created by ispconfig work regularly.
    Last edited: Apr 10, 2022
  5. migratoria

    migratoria New Member

    No solutions?
  6. nhybgtvfr

    nhybgtvfr Well-Known Member HowtoForge Supporter

    did you read / change the contents of the .htaccess and .htpasswd_stats files? the old .htaccess you copied over from the old server probably contains the wrong web## and client## as the path to the .htpasswd_stats file
  7. migratoria

    migratoria New Member

    the problem lies in the fact that if I delete the / stats folder and regenerate it from the ispcofig panel this is created correctly and the statistics work but the password authentication does not work
  8. nhybgtvfr

    nhybgtvfr Well-Known Member HowtoForge Supporter

    instead of using the protected folders setting on stats, as you claimed earlier, have you tried just changing the password from the website settings statistics tab?
  9. migratoria

    migratoria New Member

  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you remove the protected folder settings in ISPConfig again? they are not meant to be used for the stats folder.
  11. migratoria

    migratoria New Member

    I deleted the / stats folder to put the old one back.
    When I saw it didn't work I have recreated it from ispconfig by re-entering a new password in the settings of the panel.

    The folder was created and the statistics works correctly, but the password does not work even if the .htacces and authentication .htpasswd_ files are generated correctly.
    I also tried to use the option that generates a protected folder but the result doesn't change
    Last edited: May 5, 2022

Share This Page