(Error code: ssl_error_rx_record_too_long)

Discussion in 'Installation/Configuration' started by namit, Oct 21, 2009.

  1. namit

    namit New Member

    Hi have got https://ispconfig.mysite.net working with godaddy cert by going into apache config and changing certs to work with downloaded certs.

    Have setup and ticked ssl box under sitea.mysite.net but no joy when i go to https://sitea.mysite.net I get (Error code: ssl_error_rx_record_too_long).

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can not setup the cert in apache manually and use a cert in ispconfig. Remove the sl cert that you added manually and then create anew cert in ispconfig and let the csr that has been created in ispconfig sign by godaddy.
  3. namit

    namit New Member

    I only set a cert on man cp not on the reset of the virtual sites. Does settings cert on cp inter fear with virtual sites?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, if it just on the port 8080 of the controlpanel, then it does not interfere.

    Please try to recreate the SSL certificate in the website, you should check that you dont have any special characters or umlauts in the fields that contain the information on state etc. of the SSL cert as openssl might fail otherwise which can also result in the failure you got.
  5. namit

    namit New Member

    Yes its just on port 8080 have tried to recreate the cert but information in bellow boxes fill but when i try to visit site under https://sitea.mysite.net it just throws firefox error

    (Error code: ssl_error_rx_record_too_long)
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please do what I suggested above.
  7. namit

    namit New Member

    Tried that but no joy in recreating ssl cert? Is there any way that I can import the godaddy cert into it?
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to restart apache manually on the shell. If that does not help, then your cert still contains invalid characters.
  9. namit

    namit New Member

    Nope no joy

    State: Ireland
    Location: Ireland
    Organisation: LMSolutions
    Organisation Unit: Sitea
    Country: ie

    and then it fills in
    SSL Request


    SSL Certificate
    -----END CERTIFICATE-----

    SSL Bundle

  10. skilfulfox

    skilfulfox New Member

    ~/ispconfig/httpd/bin/apachectl startssl :D ?

Share This Page