Error on database server after upgrade

Discussion in 'Server Operation' started by muekno, Dec 10, 2015.

  1. muekno

    muekno Member

    Did regular update via zypper on my openSUSE 13.1 (i586) today. Server runs fine as database and DNS server in a multiserver ISPConfig 3.0.5.4p8 enviorement since more than a year now.
    Update included mysql-community-server-5.6.27-7.13.1. After this I added a new website and tried to add a database for that website. I get errors in the monitor for the database server "Unable to connect to mysql: Access denied for user 'root'@'localhost' (using password: YES)", also other database mod via ISPConfig like deleting a database resolves in an same error. If I try to log in via "mysql -uroot -p" from the server prompt all ist fine. I even can login with every other existing user and password. Looking at mysql.user all seam correct, password hashes are ok.
    MYSQL has been restarted, without errors, my.cnf has been checked for correct sqlmode.
    Need hint or help

    Thanks

    Rainer
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Does

    mysql -h localhost -u root -p

    works as well? Testing without -h localhost uses the socket while -h localhost uses a network connection.

    And the MySQL root pw. in /usr/local/ispconfig/server/lib/mysql_clientdb.conf id correct?
     
    muekno likes this.
  3. muekno

    muekno Member

    Solved, /usr/local/ispconfig/server/lib/mysql_clientdb.conf password was different. Cant remember that I changed it. Did reset root password to that i/usr/local/ispconfig/server/lib/mysql_clientdb.conf

    Thank you :)

    Rainer
     

Share This Page