Error on Install Ubuntu 22.04: Could not read ISPConfig settings file.

Discussion in 'Installation/Configuration' started by Monotoba, May 20, 2023.

  1. Monotoba

    Monotoba Member

    Hi all,
    I am trying to install ISPConfig3.2.9 on Ubuntu 22.04 and everything was going well until I got this error:
    [INFO] Installing roundcube.
    [INFO] Installing packages roundcube, roundcube-core, roundcube-mysql, roundcube-plugins
    [INFO] Installed packages roundcube, roundcube-core, roundcube-mysql, roundcube-plugins
    [INFO] Installing ISPConfig3.
    [INFO] Adding PHP version(s) to ISPConfig.
    [ERROR] Exception occured: ISPConfigOSException -> Could not read ISPConfig settings file. (/

    It's a fresh install of Ubuntu 22.04 (installed today) Running the install script with --debug didn't yield any additional output on the terminal. Is there an install log I should be looking at? Is there any known issues with Ubuntu other than the Mailman issue? I'm installing this on a friend's machine over ssh after he installed Ubuntu 22.04 on the box.

    All help is greatly appreciated!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    No. Mailman is not an issue, though. It's simply unavailable and, therefore, can not be installed.

    Run installer in expert mode, it should show you then ehy no settings file can be created.
    ahrasis likes this.
  3. Monotoba

    Monotoba Member

    Thanks for the response Till,

    I used expert mode and found what I thought was an odd error. The attempted connection to MySQL/MarriaDB was failing. After a little digging, I found that there were unknown users in the database setup as admins. I check with my friend and he confirmed he had tried to install a lamp stack and then removed it instead of reinstalling the OS as I requested when he asked for my help. After a clean install of the OS (Ubuntu 22.04), the installation only had one hiccup. He had also installed a light desktop environment with a network manager. I found I couldn't change the hostname as it would reset to "Ubuntu xxx" after each reboot. With a little googling, I found the network manager was resetting the hostname on boot. To fix this I simply had to tell the network manager what host name to use. After that, the installation went without any issues.

    I guess I did use a poor choice of wording in my first post. I did mean the known incompatibility with Mailman 3.

    Thanks again!
    Last edited: May 22, 2023
  4. pyte

    pyte Well-Known Member HowtoForge Supporter

    You absolutly don't want any of that on running on a server. If this is a testing machine, thats not directly accessible from the internet you're fine, but never install networkmanager or any GUI applications on a production server connected to the internet. There are a lot more security risks involved and you gain nothing having a GUI on a linux server.
  5. Monotoba

    Monotoba Member

    I agree with you 100%! However, this is a home project for a long-time friend who is an avid Windows user and wants to run his own web server at home. He only has a blog to show off his photos. I hosted his site on one of my servers for free for years and can't seem to stop him from uploading huge image files from his fancy professional camera. So he now wants to run his own server at home. If he wasn't a lifelong friend I wouldn't have agreed to set it up for him after he failed. I have to do this all remotely as we have lived in different states for the past 20 years. I tried to get him to purchase a copy of Windows Server as he isn't comfortable with the terninal. But he insists on having a GUI. Since he does have Secure NAS storage for his photography business and stores all his photos there, I relented... I guess he had tried to install ISPCOnfig on a Raspberry Pi and also used a docker image running on a desktop with no luck.

    To be honest, I figure after a couple of months he'll want to go back to a managed host so he doesn't have to worry about doing it all himself. But, to be a good friend, I have to humor him just long enough for me to say I told you so... ;-)

Share This Page