Error with PHP

Discussion in 'HOWTO-Related Questions' started by Tony_Soprano, May 31, 2006.

  1. Tony_Soprano

    Tony_Soprano New Member

    I'm trying to install ISP Config on SuSE 10.1 x86_64 but the install show me this errors and I don't know ho to repair...

    ./compile: line 127: 27942 Aborted                 ./configure --with-apxs=${INS
    TALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --enable-mbstring
    =all --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL
    _ROOT}/php ${WITH_OPENSSL} ${WITH_MYSQL} --disable-libxml --disable-dom --disabl
    e-xml ${WITH_ZLIB_DIR} --disable-xmlreader --disable-xmlwriter --disable-simplex
    ml --without-pear
    ERROR: Could not configure PHP
    cd: error retrieving current directory: getcwd: cannot access parent directories
    : No such file or directory
    or a segmentation fault, always @ PHP, like this:

    make: *** [ext/pcre/pcrelib/pcre_study.lo] Segmentation fault
    ERROR: Could not make PHP
    any idea?

  2. falko

    falko Super Moderator Howtoforge Staff

    You should use the 32bit verdsion of SuSE 10.1. This release seems to be quite buggy regarding x86_64 support. I couldn't get the x86_64 version to work (it refused to compile proftpd), that's why I wrote to SuSE 10.1 tutorial for 32bit.
  3. Tony_Soprano

    Tony_Soprano New Member

    well, proftpd is running without problems.
    luckly it compiled on first strike...

    the only problem with proftpd is that every user have his own dir like /home/username/ (and this is ok) but i need to share also the dir "archivio" and i don't know how...

    this is the directory tree:

    | .....

    i need to share the bold ones... any idea?
  4. falko

    falko Super Moderator Howtoforge Staff

    You could create anonymous FTP accounts for these folders.
  5. Tony_Soprano

    Tony_Soprano New Member

    Thanks a lot Falko but I'd like that the users could see /archivio/ only once logged...

    something like this:

    there're /home/a/ /home/b/ /home/c/ /archivio/

    User A logon and see only /home/a/ and /archivio/
    User B logon and see only /home/b/ and /archivio/
    User C logon and see only /home/c/ and /archivio/

    How can I do something like that?
  6. falko

    falko Super Moderator Howtoforge Staff

    That might be a little difficult. Did you have a look at the Proftpd documentation? They might have a solution for this.
  7. keybd_user

    keybd_user Member


    I have tried to install proftpd on Suse 10.1 x86_64 with no success so far.
    I have even installed and hacked the fedora Core 6 rpm from:
    To no use. There is always an error, a lib missing or some gcc problem from the configure setup.

    How did you manage to install proftd, with what version of the program?

    Thanks in advance,
  8. keybd_user

    keybd_user Member

    Got it folks!

    There is actually a proftpd 1.3.0 version that works and installs with a rpm on suse 10.1 x86_64 !!

    Just searched the opensuse site after a lot of work trying to compile the source code.
    There is simply to much dependencies missing.
    But the rpm installs great!
    Wit no problem.
    When proftpd starts it complains with a IpV6 problem.
    but aparently it does work, accepts connections.
    so in principle it is ok to install.
    I will try today a go with ISPconfig.

  9. falko

    falko Super Moderator Howtoforge Staff

  10. keybd_user

    keybd_user Member

    After an entire day loosing my patience with an "up-grade" from version 10.0 to the 10.1 in a x86_64 machine I actually also detected the problem!
    I had to make a reinstall.
    It make me loose a lot of time. But it was worthy.

    Also for those that might be interested and this is something even I have a hard time explaining to myself :) :) it is possible to upgrade the kernel of 10.0 directly to the new 10.1 smp.
    Just download the kernel from a suse mirror (inst-source dir) near you.
    At least in my server it did not afect nothing. Works like a charm!
    Just the subfs stops working and the mounts for dvd's floppys and usb falsh drives must be made manually and of course some small changes to the /etc/fstab must be made. Which, for a server, it is actually a really good thing!

  11. keybd_user

    keybd_user Member

    Hi Falko,

    The installation of SuSE 10.1 on x86_64 is perfect !
    The only problem seems to be the Mirrors have wrong versions of many libraries in their

    Has mentioned before I could see that nothing would compile under SuSE 10.1 because of the wrong glibc and also of other packages if one gets the packages from the mirrors!

    I have made like this:
    In your perfect setup howto instead of eliminating the DVD source that must be burned from the isos supplied from SuSE site
    (download the 5 isos + add-on and then make a single dvd iso: )
    I let the DVD be the first source in yast2.

    I only added the ins-source mirror near me:
    You can choose any other one.
    In fact the yast2 is correct :) :) you should not let the dvd copy be the last one :) :)
    In this manner the installation goes perfect!
    One can also make the other online sources that yast makes automatica other then the newly added inst-source be off and refresh = off
    So they will not bother.

    Even proftpd compile in the first attempt and no wrong libs are picked in the inst-source mirrors.

    To make it simple:
    Make cd isos to dvd:
    When installing let dvd be the first source.
    Add mirror with inst-source but let it be the last one.

    Everything goes smoothly like this!
    The perfect setup also works for x86_64!

  12. keybd_user

    keybd_user Member

    I must correct what I have said.
    Maybe it is yast2 that gets wrong versions when accessing online mirror sites.

  13. falko

    falko Super Moderator Howtoforge Staff

    Thanks for your hints. :)
  14. keybd_user

    keybd_user Member

    Well ... maybe the SuSE team at the time of my Second installation did already patched the bug on the installer:
    And with the online yast up-date during install the correct yast packages are installed and patched.
    And now it works ok.
    I also noticed that the windesque zmd.exe (YUCK!) is maybe the responsible to mess the installation ...
    It makes a "small" log on /var/zmd-backend and that log indicates that indeed it is the new Novell zmd that is perhaps messing up the install (just take a look at all the package info .... that at least delays the instal ... ).
    What is your opinion on this issue?

    In my computer everything seems to be perfect, and so far very stable.
    There is also a new warning over PHP up-dates:

  15. falko

    falko Super Moderator Howtoforge Staff

    My opinion is: don't use SuSE on a server! :D
  16. keybd_user

    keybd_user Member

    Hi Falko,

    What would be the winner of all available distributions ( -except Red Hat and SuSE enterprise off course) in your opinion to make a great server?
    I am really just a Linux user. I am a programmer but in this particular case I must make a server and put it on a datacenter.
    I use Linux since 1996 :eek: (Red Hat 4 slackware 3.1) and just loved all those "hand made" instalations from the early days, it was beautifull :) Just for fun and pleasure.
    But the point is a 64 bit server deserves a great install ... so what would be the solution?
    Tyan MB + 2x Opterons Dual Core + 16GB Mem.
    The raid controller is a 3Ware 9550SX so kernel 2.6.16 brings the drivers and is perfect.

  17. falko

    falko Super Moderator Howtoforge Staff

    I always use Debian, but you can also try Ubuntu, it might have better support for your hardware.
  18. keybd_user

    keybd_user Member

    AHA! I see exactly what you mean. I totally agree.
    I have a Debian install on a Dell 1,8GHz from some years ago, and I totally love the distro. It is so very very cool.
    For a server is a far more "lighter" and "agile" distribution. Must have more performance them SuSE ( more desktop oriented... it places 1,3GB of programs like xemacs, and documentation and a lot more from the dependencies, that must be removed after install even when one chooses the text only install :) . )
    Never tried Ubuntu :( .
    But hardware support in my case is far better on SuSE.
    I tried to play with the RedHat Enterprise clone, CentOS, and it was a mess ...
    Specially the kernel recompile and install.
    I managed to do it, but it was a pain. Not to mention the driver support for the initial kernel version ...
    SuSE is not the ideal, I know, but it offers a lot of ease of use and also a great support for the Java development that is going to take place on that server.
    ( By Java development I mean Java testing ... )
    Well .. one can not have perfection, be we can sure try to be close :)

  19. falko

    falko Super Moderator Howtoforge Staff

    That's true... ;)

Share This Page