etch: Segmentation fault /usr/sbin/amavisd-new-cronjob sa-sync

Discussion in 'Server Operation' started by mindrail, Aug 15, 2007.

  1. mindrail

    mindrail New Member

    spamassassin 3.1.7-2
    amavisd-new 2.4.2-6.1
    clamav 0.90.3-0volatile1

    About 3-4 times a day I get

    /bin/sh: line 1: 29866 Segmentation fault /usr/sbin/amavisd-new-cronjob sa-sync

    mailed to me.

    The '29866' value changes every time.

    /usr/sbin/amavisd-new-cronjob effcetively su's to amavis to run the command

    /usr/bin/sa-learn --sync

    which has no problem when run on the cmd line.

    Has anyone seen this?
  2. falko

    falko Super Moderator ISPConfig Developer

    Not sure why this happens, but you could try and change /bin/sh to /bin/bash in the first line of /usr/sbin/amavisd-new-cronjob.
  3. bschultz

    bschultz Member

    I'm getting the same error, and I've tried changing the first line to /bin/bash, but the email still says /bin/sh. I've tried rebooting, and it still doesn't reload the cronjob to use the /bin/bash.

    Any ideas on how to make this reload this cronjob?

Share This Page