Fail to open ISPConfig site: firefox 8182

Discussion in 'Installation/Configuration' started by BigB, Jul 21, 2005.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    The error means that you are in a directory that does not exist anymore, nothing serious. Is the certificate working that you cretaed or not?
  2. nenad

    nenad Member

    Yes, I realised that.
    After I "reinstalled" certificate according to your instructions everything works fine.
    Thank you very much. Your advices are allways great help.

    BTW what means:

  3. falko

    falko Super Moderator Howtoforge Staff

    This happens the first time when you set up quota. That's normal, nothing to worry about.
  4. badben

    badben New Member


    I have followed the changes to amend the detail of my certificate an now ispconfig will not restart and I can't connect to theserver at port 81.

    It won't let me access emails either.
  5. badben

    badben New Member

    emails now work as I restarted saslauthd and postfix.

    port 80 works also, it is just that won't work.

    It just says "The connection was refused when attempting to connect to https://...."

    netstat -tap shows nothing for ispconfig and i've tried to restart ispconfig-server three times, no joy.
  6. badben

    badben New Member

    Sorry to be a pain but it now works.

    I must have done something wrong as I have redone the changes to the cert and the ispconfig apache now works.

    On the plus side I have now found were all of the ssl cert stuff is and a bit more about how they work.

    Sorry again, but I paniced a bit.
  7. falko

    falko Super Moderator Howtoforge Staff

    No problem! :) It's good that it's working again.
  8. New Member

    SSL working

    My SSL certificate is not working properly when the session expired.

    I did a wrong choice in the initial setup of ipconfig, but I do not want to reinstall. my ispconfig runs on . When I load this address it works fine (except that my certificate always generates a browser warning). When the session times out, however, I get refered to .This is probably because of my bad choice in the install. How can I change the path to just www and the part to I want to set up a webhost and really don't want customers to see that other domain.

    Also, it would be nice if anyone could tell me how to set up a ssl certificate that does not generate the warnings, without having to pay a lot of $$ for an authority. Thanks. :)

    You have helped me already quite a lot. Thank you soo much. Great tool. Great support and all that for free, I can't believe it!
  9. falko

    falko Super Moderator Howtoforge Staff

    Please set the correct FQDN in /home/admispconfig/ispconfig/lib/ and in /root/ispconfig/httpd/conf/httpd.conf and restart ISPConfig:
    /etc/init.d/ispconfig_server restart
    You don't get such a certificate for free.
    I'm buying my certificates at
  10. New Member

    Danke. But I think I read somewhere that you can set up your own authority. But yeah, as far as I know this wouldn't really make sense since you need to have a trusted party between the site and the user (browser) as far as my knowlege of security goes.

    Ich bin uebrigens auch Deutscher ;)
  11. nvn

    nvn New Member

    Restart ISPConfig afterwards.[/QUOTE]

    Perfect.... it's working now..
  12. asmadius

    asmadius New Member

    Is there anything wrong with this.... offers free certs for domains, emails, servers...

    are these ok or is ther something wrong with them. I've used it last year but it don't seem like anybody knows about them or there is something not quit ok. :confused:
  13. falko

    falko Super Moderator Howtoforge Staff

    I think most browsers don't have included that's why you will continue to get warnings with their certificates. So there would be no difference to using your own certificate.
  14. asmadius

    asmadius New Member

    OK thanks for the info I didn't think about that.:eek:
  15. AndyF

    AndyF New Member

    Sorry for bumping an old thread, but this can be used to change your install so that you don't have to keep putting the password in for the certificate on boot, without having to do a reinstall of ISPConfig.


  16. kingtech

    kingtech New Member

    this needs a sticky!!! I also had SSL probs after installing with perfect install for centos 4.3... somewhere along the line I created a self signed cert and could not figure out why the ISPConfig would not work after reboot... was wanting the passphrase....

    thanks for the help falko! I have a smooth web server running now!
  17. nenad

    nenad Member

    I noticed that sometimes after re-installation of ISPConfig, or after new installation, Firefox is complaining about certificate. Usually I create a new certificate, but few days ago I tried different approach:

    I deleted certificates in Firefox, and then it accepted certificate from ISPConfig webiste, withouth compaining about certificate issue any more
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Firefox is complaining about a certificate if it is used on two servers.

    For example: If you have 2 servers and you entered the same values in the certificate setup, firefox will complain against the 2nd server. If you delete the cert in firefox and browse the 2nd server again, everything is ok, but if you go to the 1st server, it will complain there now :)
  19. nenad

    nenad Member

    Actually, you don't need to have 2 servers, it is enough to reinstall ISPConfig with same data (what most useres actually do) on the same server.

    BTW I have to serevers and I entered same data, and after deleting certs from Firefox it's is not complaining neither for server200 neither for server 201
  20. cybere

    cybere New Member

    SSL certificates


    I have attempted to complete the instructions provided by Till and falko, on the creation of new certificates. However i am getting an error generated, due to there not being a server.key2 file. The directory structure is fine up until then but there are only 2 files in there:

    README.csr and server.csr

    this file server.key2 is not to be found anywhere on myserver, and im just wondering if that needs to be replaced with the file i do have.

    The browser is operational, but im unable to view ispconfig admin.

    error is as follows:

    Your certificate contains the same serial number as another certificate issued by the certificate authority. Please get a new certificate containing a unique serial number.

    Last edited: Dec 14, 2006

Share This Page