FC 4 Perfect Install

Discussion in 'HOWTO-Related Questions' started by latcarf, Feb 7, 2006.

  1. latcarf

    latcarf New Member

    Hi All

    Been sometime since I needed to come by. I just did a fresh install of FC4 and following the HowTo. I didn't get very far... when I went to install apt...
    [root@server1 ~]# rpm -ivh http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm
    this is what I got
    Retrieving http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc 7-6.fc4.i386.rpm
    /var/tmp/rpm-xfer.lxfsMP: not an rpm package (or package manifest):
    a recopy, retry got this
    Retrieving http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm
    warning: /var/tmp/rpm-xfer.yaGUEo: Header V3 DSA signature: NOKEY, key ID 1ac70ce6
    Preparing...                ########################################### [100%]
       1:apt                    ########################################### [100%]
    error: unpacking of archive failed on file /usr/bin/apt-cache;43e7e254: cpio: read
    and one more try for kicks and grins got this
    Retrieving http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm
    error: /var/tmp/rpm-xfer.sduvJ7: headerRead failed: hdr blob(42126): BAD, read returned 24120
    error: /var/tmp/rpm-xfer.sduvJ7 cannot be installed
    any rational thoughts on what is going on? I did a full FC4 install and there were errors noted during install.

    thanks !
  2. falko

    falko Super Moderator ISPConfig Developer

    Maybe your hard disk is full? What's the output of
    df -h
  3. latcarf

    latcarf New Member

    Hi Falko

    It is a brand new 160GB SATA. Setting it up so I can transfer my web stuff to it for more room.

    I ran Up2date last night and that hosed my graphics. I am gonna go bu Fedora and get the latest version of the ISOs and try a reload see what happens.

  4. latcarf

    latcarf New Member

    aahhh! success! but I just did the server install as outlined in your HowTo. Would lead one to believe that the HowTo doesn't support a full install but that does not make sense. Could have been a glith in the install also. I guess if I get bored enough I can try a full install again. :D

    Mean while... I'll just install stuff as I need it.


    p.s. not sure it matters now but df -h comes back as
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/sda3             144G  2.1G  134G   2% /
    /dev/sda1              99M  9.3M   85M  10% /boot
    /dev/shm              125M     0  125M   0% /dev/shm
    Last edited: Feb 8, 2006
  5. falko

    falko Super Moderator ISPConfig Developer

    That's no problem.
  6. latcarf

    latcarf New Member

    p.s. forum is looking good... lot of extras since I was here before. :)
  7. latcarf

    latcarf New Member


    Okay I got bored and did the full install after all...

    Everything went fine with the install and then following the Perfect Setup... until I rebooted :(

    when it was doing the checks and got to "Checking filesystems" I get;

    fsck.ext3 Unable to resolve 'Label=/'
    and it threw me into shell.

    In the Perfect Setup under Quota we edited this line in /etc/fstab to add usrquota and grpquota. I blocked and copied so I don't believe I made a key error but maybe I didn't save it right or something.

    Can I fix this from the shell? I am weak at best with console so.... It did cross my mind I could recreate /etc/fstab and copy it there through the shell and hopefully overwrite the old. Now the question is... what would the shell commands be to copy from floppy to dir?

    I got a little more info... when it goes to shell it gives a couple options.

    Enter root password for maintenance.
    (or type Control-D to continue) Control D just reboots back th the same problem.

    Entering root password gives
    (repair filesystem) 1 #
    I just don't know what to enter here. Exit does just that and reboots.

    I figured out the copy command (cp) but cannot get either linux machine to recognize the floppy drive e.g. cp /floppy or /floppy drive or /fd0. I have tried every imaginable combo and name.
    Last edited: Feb 11, 2006
  8. cybereatl

    cybereatl Member

    Let me tell you, that I did same thing and have to reinstall again, my fedora core 4 got this:
    /dev/VolGroup00/LogVol00 / ext3 defaults,usrquota,grpquota 1 1

    and the howto show just / ext3 defaults,usrquota,grpquota 1 1

    after trying a lot I just decide reload, and when got back to that part just leave as is and add up usrquota,grpquota.

    If there is any option!!! it's too late for me, but a good chance for you.

    Good luck!!
  9. operajill

    operajill New Member

    error : Install apt FC4


    hope you guys can give me a few how to's. i'm a newbie and was assigned to set up a webserver. i followed the perfect setup for fc4 and came across an error when i try to install: (installing as administrator not as root)

    rpm -ivh http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm

    error came as:

    warning: /var/tmp/rpm-xfer.XFQMAi: Header V3 DSA signature: NONKEY, key ID 1ac70ce6

    error: can't create transaction lock on /var/lib/rpm/_db.000

    did the same command as root but error came as:

    error: skipping http://ftp.freshrpms.net/pub/fedora/linux - transfer failed - Unkown or unexpected error

    segmentation fault

    thanks in advance.
  10. falko

    falko Super Moderator ISPConfig Developer

    I guess you copied the whole /etc/fstab from the tutorial instead of just adding
    to the appropriate partition? :eek:
    The /etc/fstab is just an example, it looked like that on the system I used to write the tutorial, and I think yours had been different. I don't want you to copy it, I just want you to add
    to it.
    I guess you did not make a backup of the original /etc/fstab? Then you should consider a reinstall...
  11. falko

    falko Super Moderator ISPConfig Developer

    Yes, that's the way it is meant to be.
  12. falko

    falko Super Moderator ISPConfig Developer

    You have to run this as root! If you get this transfer error, you can do it like this instead:
    cd /tmp
    wget http://ftp.freshrpms.net/pub/fedora/linux/extras/4/i386/apt-0.5.15cnc7-6.fc4.i386.rpm
    rpm -ivh apt-0.5.15cnc7-6.fc4.i386.rpm
    Or you use yum instead of apt to install all the packages in the tutorial, instead of
    apt-get install <package_name>
    you run
    yum install <package_name>
  13. latcarf

    latcarf New Member

    I'm scratching my head...

    Are you saying that something did not install correctly?
  14. falko

    falko Super Moderator ISPConfig Developer

    No, I'm saying that you removed your original /etc/fstab and replaced it with the one from the tutorial. That's why it is not working. The one from the tutorial is just an example to show you where you have to put
    You should have kept your original /etc/fstab and just put
    into it.
  15. latcarf

    latcarf New Member

    aahhh... I see the light! :) Just a note, I only replaced the 'Label=/' line and with the exception of usrquota, grpquota they were the same.

    I did another install but I so far I have only used Install apt for Fedora, Install Some Software, and ProFTP sections from the Perfect Setup.

    I am not doing a post install of ISPConfig and it seems the other parts are geared toward that, is that correct? I am just running a single web and FTP site.
  16. falko

    falko Super Moderator ISPConfig Developer

    The Apache configuration (disabling PHP globally) is made for ISPConfig; if you don't disable PHP you can use the setup for any server.
  17. latcarf

    latcarf New Member

    You mean the part were we comment out Addhandler and Addtype, correct? I didn't run the Apache setup, isn't Apache part of the FC4 core install?

    The install is up and running and I copied my web stuff over to it. When I redirect my router virtual server over to the new machine it works until I shut down the old machine. As soon as I hit refresh it gives me a blank page. Start the old machine back up, hit refresh, and it is back.

    Been trying to figure out all day why that is happening. What fun!
  18. falko

    falko Super Moderator ISPConfig Developer

    It depends on which package group selections you made during the installation from the CDs.

    Please double-check your router's settings. Maybe you have to reboot your router.
  19. latcarf

    latcarf New Member

    I did a "Complete" which seems to be all and then some.

    I did the double check and there is a "Apply Settings" button which I used. I do remember seeing something about rebooting so I will definitely double check that. It crossed my mind today that it may be the named.conf file. I have not edited it yet. I remember I did copy my proftpd.conf to the new hard drive but don't recall doing the same with named.conf.

    Speaking of which... isn't there a Linux utility for doing drive images? Seems it would be easier to image my old drive onto the new drive and then add whatever I want after the fact. correct?

    Some late night follow-up... I had a really hard time making a network connection from my windoze machine to this new one. I finally realized that I did not disable SELinux since as the set-up states it is done in ISPConfig (which I did not install). After I finally found where the setting for SELinux were I made some udjustments to the Samba settings and ta da!!!

    Any suggestions regarding the SELinux settings for HTTPD? I did localhost and got my page but when I clicked a link to my FTP site on the page the connection was refused.
    Last edited: Feb 14, 2006
  20. falko

    falko Super Moderator ISPConfig Developer

    Have a look at these two tutorials:

    I recommend to disable SELinux. Open /etc/sysconfig/selinux and set SELINUX to disabled:
    Then reboot your system.

    Also have a look here: http://fedora.redhat.com/docs/selinux-faq-fc3/index.html#faq-div-controlling-selinux

Share This Page