FC9 -> FC11: lost abilities/configurations

Discussion in 'Installation/Configuration' started by kaza, Jul 11, 2009.

  1. kaza

    kaza New Member


    I had FC9 installed for 2-3 months and decided to move to FC11.
    In the FC9 desktop (GNOME) I had "gkrellm" monitor started
    by entry in the ~/.gnome2/session files and also a "gnome-terminal"
    with a particular geometry which calls "/bin/tcsh -c top". I also have
    ~/bin/chtitle_linux script which sends particular codes to set the title
    of the gnome-terminal.
    At some point I decided to move to FC11 (mostly because I couldn't
    figure out how to get sources for recompiling the kernel - searched the
    install DVD but found only empty sources directory). I downloaded the 4GB
    iso image file and burned it on a DVD, did "tar ...; gzip ..." for my home directory
    and burned it on another DVD, rebooted with the FC11 DVD, selected
    "upgrade existing system" option (maybe it was a mistake? Maybe
    I should've selected "install" instead of "upgrade"?) and started the upgrade.
    After the system had been upgraded (I thought it'll allow me to change
    drivers compiled so I'll add SCSI U320 card support in addition to SAS
    I'm currently running on but apparently it just retained drivers configuration
    from FC9). After finishing the upgrade and rebooting, I was glad to see that
    my desktop background, two launchers of gnome-terminal (at different
    sizes and locations) and 3 launchers of "nedit <file>" retained.

    However, few things were changed/lost:

    1) When activating the launcher of the "gnome-terminal", there is an
    error messae at the beginning:

    Unknown colorls variable `rs'.

    I did some searching, copied "/etc/DIR_COLORS" to "~/.dir_colors",
    commented the line with "CAPABILITY" but still the same error

    2) Also about gnome-terminal start: apparently it doesn't sources the
    ~/.tcshrc, maybe for the same reason it fails with the "colors" error above.

    3) An attempt to run "chtitle_linux" tcsh script (which just prints the codes
    to change the title) results in the same error message:

    Unknown colorls variable `rs'.

    It looks like running tcsh encounters this error.

    4) The "gkrellm" didn't open despite being in the ~/.gnome2/session file.
    Attempting to call it manually resulted in the following error:

    <[email protected]>.../kaza>gkrellm: error while loading shared libraries: libssl.so.7: cannot open shared object file: No such file or directory

    Attempting to recompile the sources of gkrellm resulted in the error message:

    Package libpng12 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libpng12.pc'
    to the PKG_CONFIG_PATH environment variable

    5) Attempting to start "gnome-terminal in a command line (from gnome-terminal
    already opened by the launcher) results in the terminal window opening
    for a fraction of a second then closes with system alert sound
    without displayinh anything. At the first reboot after the upgrade
    it printed something about Gnome config daemon not avaliable (something
    like that) but after additional reboots nothing is printed.

    6) SELinux warns about some processes attempting various violations with the
    first being:

    SELinux is preventing gdm-session-wor (xdm_t) "unlink" to .dmrc (user_home_t).

    Can it be the cause of these multiple problems: changed policies of
    what's allowed? I don't have enough internal LINUX knowledge
    to understand the consequences of changing various booleans
    in the SELinux: can I make my PC volunerable to external attack by
    allowing something?


    These are the things I see ringht now. I have about 12 years of UNIX/LINUX
    experience at work as a user but it's the first time I'm my own sys-op
    by installing LINUX at home so I'm prone to many beginners errors.
    Any ideas as to how to fix these problems?
    Are the fixes of the type "edit some configuration file"
    or a complete system install is required? I remember reading
    that upgrading from FC9 to FC11 isn't supported, maybe I'm
    punished for trying it anyway?

    Thanks in advance for any help,

Share This Page