fencing problem

Discussion in 'Server Operation' started by sachin1361, Sep 9, 2007.

  1. sachin1361

    sachin1361 New Member

    I have been using RHEL-5 kernel

    I am using two Linux servers named web03 and web04 which is connected to Two brocade switches which are furhter connected to Dell EMC CX300 array.

    We are implementing cluster in these two linux servers and we are using system-config-cluster utility. These two servers have two NICs cards each , named private (network public ( network connected to EMC storage whereas private network connected to cross cable( one NIC card of linux server is connected through cross cable to other linux server which is having IP and is the configuration of my /etc/cluster/cluster.conf file.

    <?xml version="1.0" ?>

    <cluster alias="http_cluster" config_version="4" name="http_cluster">

    <fence_daemon post_fail_delay="1" post_join_delay="3"/>


    <clusternode name="web03" nodeid="1" votes="1">


    <method name="1">

    <device name="brocade_top" port="7"/>
    <device name="brocade_bottom" port="7"/>






    <fencedevice agent="fence_brocade" ipaddr="" login="admin" name="brocade_top" passwd="123456"/>

    <fencedevice agent="fence_brocade" ipaddr="" login="admin" name="brocade_bottom" passwd="123456"/>





    The problem is :

    1)whenever i start cman services , it hangs on starting and stopping of fencing daemon.and when i check /var/log/messages , it displays:

    web03 fenced [9255]: fence "web04" failed
    webb03 fenced [9255]:fencing node :"web04"

    I once added web04 in cluster ,didnot work, so I delete cluster.conf file and reconfigure cluster.conf.

    Why /var/log/message file shows fencing error in log files when web04 is not in cluster.conf file.

    I think there are some other configuration file from where web04 is bound to fencing.

    From where can I delete web04 entry so that fencing is done ignoring web04 server.

    2) whenever I run system-config-cluster command , it displays the message as :

    Because this node is not currently part of cluster, the management tab for this applicaiton is not avaiable.

    and when i check log file, again same error message:

    web03 fenced [9255]: fence "web04" failed
    webb03 fenced [9255]:fencing node :"web04"

    why is this so???

    All services are running file such as
    service rgmanager restart
    service clvmd restart

    Please clarify these issues!!


Share This Page