File attributes error during upgrade and missing column in database

Discussion in 'Installation/Configuration' started by zimon, Sep 11, 2020.

  1. zimon

    zimon New Member

    I have found two issues with the latest install of ISPConfig 3.1 and the upgrade to 3.1.15p3 when installing on CentOS 7.8.2003. I used the stable release for both the install as well as the upgrade.

    Missing column in database
    After the installation is completed I tried to add a new domain through the Web interface, which didn't work since the column fastcgi_php_version on table web_domain is reported missing. Going through the incremental SQL files folder I noticed that although column first is added through file upd_0031.sql, it is later removed through file upd_dev_collection.sql in this section:
    -- we have to decide whether to delete the column or leave it there for investigating not-converted entries
    -- ALTER TABLE `web_domain` DROP COLUMN `fastcgi_php_version`;​
    Although the line is commented out in the file, it still gets executed on my system and thus being removed from the table. I had to manually add the column back to the table.

    File attributes error during upgrade
    When I executed the automatic upgrade using I get the following error:
    PHP Warning: fopen(/var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter): failed to open stream: Permission denied in /tmp/ on line 466​
    The reason for this is that the i flag is added to the file attribute during the installation, but the upgrade script does not remove the flag before attempting to read/modify it. I solved this by executing chattr -i on the file after the installation, but before running the upgrade script.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    What you did is a downgrade from 3.1dev or 3.2beta to the much older version 3.1.15p3, and that's why it failed. Such downgrades must fail as you can not install an older version with an incompatible database layout on top of a much newer version, so there is no bug here and no missing database column.
  3. zimon

    zimon New Member

    You are right. I used the link to download ISPConfig 3.1 (which I guess downloaded the development version) rather than the recommended after which I ran the command and apparently was downgraded to 3.1.15p3.

    This server is now in production. What do you recommend I do? Can I stay with 3.1.15p3 or will I run into issues because of the downgrade? Or is it possible to reinstall the 3.1 git version without loosing data?

Share This Page